Author Topic: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7  (Read 11112 times)

Offline dbs

  • Betatester
  • **
  • Posts: 8036
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #25 on: August 17, 2016, 08:11:23 PM »
Schau mal in die php_error.log im Ordner /var/logs/

Offline Craxx

  • Posts: 265
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #26 on: August 17, 2016, 08:16:38 PM »
da steht nur folgendes drin:

created: [2016-08-17T18:44:55+02:00]
Craxx;)

Offline dbs

  • Betatester
  • **
  • Posts: 8036
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #27 on: August 17, 2016, 08:46:22 PM »
Du könntest uns sagen welche PHP-Verison du nutzt und das Upgrade nochmal hochladen.
Es kommt öfter vor, dass nicht alle Dateien übertragen werden.

Offline Craxx

  • Posts: 265
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #28 on: August 18, 2016, 09:29:23 AM »
Guten Morgen,

ich habe am Webserver PHP 5.6 eingestellt.
Ich werde das nochmal auf einem Spielsystem testen, wenn ich Zeit habe. Das war gestern ein Livesystem, das war etwas doof. Läuft aber wieder mit dem Rückspielen der Dateien und des Datenbankbackups.
Craxx;)

Offline klaumich

  • Posts: 92
  • Gender: Male
  • Ziemlich Ahnungsloser
    • michler-web
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #29 on: September 08, 2016, 02:08:29 PM »
Hallo WB "Gemeinde" .... ich bin ja gerade am Updaten meiner ganzen Domains die ich betreue, bisher haben die Updates von 2.8.1, 2.8.2 auf 2.8.3 und dann weiter auf SP7 reibungslos funktioniert! Auch der Update von 2.8.3 SP4 auf SP7 flutschte!
Jetzt habe ich gerade wieder einen Update von 2.8.2 auf 2.8.3 erfolgreich durchgeführt. Beim anschließenden Upgrade auf SP7 erhalte ich dann eine Fehlermeldung "Step 4 : Modify PRIMARY KEY in settings table unable to insert values into new table `settings` FAILED:-(

Der Rest ist mit "Ok" durchgelaufen! Jetzt steh ich wieder mal im Wald .... wie oder wo kann ich das fixen ?! Oder kann ich die Meldung auch ignorieren ?  :?

Viele Grüße
Klaus

#Edit: ömp ..... hat sich erledigt, habe im Englischen Bereich ein Posting gefunden dazu, UpdateScript noch mal angeschubst und dann lief es ohne Fehler durch!
« Last Edit: September 08, 2016, 02:17:27 PM by klaumich »
Immer in der Hoffnung, dass das Licht am Ende des Tunnels der Ausgang ist ...
[WB vers. 2.12]

Offline jacobi22

  • Posts: 5879
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #30 on: September 08, 2016, 02:25:12 PM »
Quote
Oder kann ich die Meldung auch ignorieren ?

würde ich nicht ignorieren - in diesem Fall einfach das Upgrade-Script noch einmal starten.

Dieser Vorgang läßt sich übrigens unendlich und zu jeder Zeit ohne irgendwelche Negativfolgen starten. Ursache in den meisten Fällen: Die Tabellenstruktur der vorhandenen Tabellen passt (noch) nicht zur neuen Struktur in SP7 - trifft übrigens für Module genauso zu wie für den Core. Die Meldung, wie hier mit STEP 4 ist dann immer eine Momentaufnahme, wenn das Script an genau dieser Stelle ist. In deinem Fall soll er die alten Daten einlesen, die tabelle löschen, dann mit der neuen Struktur wieder erstellen und befüllen und als letzten Schritt ein paar Extras setzen, hier der PRIMARY KEY. In aller Regel sind diese Aufgaben bis auf den letzten Schritt in deinem Fall erledigt und das Script hat dann nur noch diesen einen Job, der zu erledigen ist.

Für eine Version des News-Moduls hab ich mal 6 Versuche benötigt. In jedem Schritt wurde dann etwas mehr umgeschrieben, bis er dann durch war.
Wer nicht will, findet Gründe, wer will, findet Wege.

Offline klaumich

  • Posts: 92
  • Gender: Male
  • Ziemlich Ahnungsloser
    • michler-web
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #31 on: September 08, 2016, 02:41:15 PM »
Danke für das wieder mal sehr fixe Feedback  (Y), wie in meinem letzten Post geschrieben lief das Script beim zweiten Mal fehlerfrei durch ....

Leider hab ich jetzt ein ganz anderes Problem, irgendwie hat sich der media Ordner im Backend auf MEDIA_DIREKTORY geändert, jetzt ist der Verweis auf sämtlichen Seiten in dieses Verzeichnis, was es aber in der Ordnerstrukture auf dem Server gar nicht gibt  :-o
Auf dem Server heist der Ordner nach wie vor media und sind auch sämtliche Bilder und Unterverzeichnisse vorhanden ..... Der Wald in dem ich stehe war grad wieder licht und nun isser wieder dicht  :|
Wenn ich auf Medien klicke steht eben dort auch MEDIA_DIREKTORY ..... und das Backend zappelt solange hin und her bis ich Server Error bekomme im Medienfenster!
« Last Edit: September 08, 2016, 02:55:31 PM by klaumich »
Immer in der Hoffnung, dass das Licht am Ende des Tunnels der Ausgang ist ...
[WB vers. 2.12]

Offline klaumich

  • Posts: 92
  • Gender: Male
  • Ziemlich Ahnungsloser
    • michler-web
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #32 on: September 08, 2016, 02:49:46 PM »
Hier noch ein Link zu nem Screenshot http://www.flarakg32.de/temp/Zwischenablage01.jpg

im Seitenquelltext steht dann der Verweis auch auf src="http://www.flarakg32.de/MEDIA_DIRECTORY/missle_gvsk.gif", anstatt wie eigentlich korrekt auf src="http://www.flarakg32.de/media/missle_gvsk.gif" wo die IMG´s auch liegen
« Last Edit: September 08, 2016, 02:58:05 PM by klaumich »
Immer in der Hoffnung, dass das Licht am Ende des Tunnels der Ausgang ist ...
[WB vers. 2.12]

Offline jacobi22

  • Posts: 5879
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #33 on: September 08, 2016, 03:09:40 PM »
MEDIA_DIRECTORY ist ein Platzhalter für das Verzeichnis, das in deinen WB-Optionen eingetragen wurde. (Erweiterte WB-Optionen -> Servereinstellungen -> Medienverzeichnis).
Dieser Platzhalter wird dann bei der Ausgabe durch das entsprechende Verzeichnis ersetzt

Ich denke mal, du meinst auch etwas anderes

Hier der Quellcode eines eingefügten Bildes im Wysiwyg-Editor


der Bilderpfad zeigt meine WB_URL

In der Datenbank schaut das aber so aus



dort wird der Pfad zum Mediaverzeichnis durch {SYSVAR:MEDIA_REL} ersetzt.

Nun gibt es Leute, die meinen, den Pfad im Wysiwyg-Editor manipulieren zu müssen, um mit relativen URLs arbeiten zu können. Das passiert bewußt oder auch bei der Übernahme aus einem HTML-Projekt oder per Copy&Paste aus einem anderen WB. Das WB-System arbeitet aber (wie jedes mir bekannte CMS übrigens auch) mit absoluten Pfaden.

Unter bestimmten Umständen steht dieses {SYSVAR:MEDIA_REL} dann auch im Quellcode des Editor, weil der dortige Pfad nicht aufgelöst werden kann, nicht mit dem übereinstimmt, was als WB_URL in der config.php steht. In diesem Fall wäre der Pfad im Editor dann ungültig, im Frontend würde es je nach Schreibweise vielleicht noch gehen. In diesem Fall einfach das betreffende Bild neu auswählen und abspeichern.

Hintergrund dieser Platzhalter-Ersetzung ist es, in der Datenbank keinen Link zur WB_URL oder zum Media-Verzeichnis zu haben, das man bei einem Umzug ersetzen müßte

Zum letzten Post, der grad rein kommt:
läuft auf die Geschichte hinaus, die ich eingangs erwähnt hab. WB-Einstellungen. Eventuell fehlt diese Einstellung, auch wenn ich meine, dein Media-Verzeichnis müßte ohne solche Angabe im Root von WB liegen. Muß ich glatt mal probieren....
Wer nicht will, findet Gründe, wer will, findet Wege.

Offline klaumich

  • Posts: 92
  • Gender: Male
  • Ziemlich Ahnungsloser
    • michler-web
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #34 on: September 08, 2016, 03:22:13 PM »
Okeee stimmt, unter Optionen/Erweitert steht MEDIA_DIREKTORY ..... nur warum wurde das beim Update "überschrieben"/geändert ?? Auch unter den Maileinstellungen fehlen die Einträge und ich kann jetzt diese auch nicht eintragen, weil ich das PW nicht zur Hand habe, aber wenn ich diese Felder nicht ausfülle lassen sich die Einstellungen nicht ändern .... *heul" ....

Bisher war das bei den schon durchgeführten Updates nie ein Problem  :?
Immer in der Hoffnung, dass das Licht am Ende des Tunnels der Ausgang ist ...
[WB vers. 2.12]

Offline klaumich

  • Posts: 92
  • Gender: Male
  • Ziemlich Ahnungsloser
    • michler-web
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #35 on: September 08, 2016, 03:37:50 PM »
leider lässt sich die Einstellung /media durch speichern auch nicht übernehmen, hab die Einstellung auf PHP MAIL stehen lassen, dann geht das mit dem Speichern ... nur danach steht wieder MEDIA_DIREKTORY im Feld Mediaverzeichniss  :cry:

Bei einem bereits geupdateten Sytem sieht die Erweiterte Einstellung im Bereich Server auch ganz anders aus (grafisch) wie bei dem "Problemkind" jetzt .....
Immer in der Hoffnung, dass das Licht am Ende des Tunnels der Ausgang ist ...
[WB vers. 2.12]

Offline jacobi22

  • Posts: 5879
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #36 on: September 08, 2016, 03:40:24 PM »
bin grad mit der Chefin im Dialog - schaut wohl so aus, als würde der Platzhalter eingesetzt, wenn der übergebene String leer ist, was in der Theorie aber eigentlich nicht auftreten soll, der Wert steht ja in der install-data.sql (( 'media_directory', '/media'),) - wird allerdings nur verwendet, wenn er nicht!! vorhanden ist.

Könnte mir vorstellen, das dies mit dem ersten mißlungenem Upgrade passiert ist, da dort ja auch genau diese Stelle angemeckert wurde.

Vorschlag 1: Verzeichnis in den WB-Optionen manuell eintragen

Quote
Auch unter den Maileinstellungen fehlen die Einträge und ich kann jetzt diese auch nicht eintragen, weil ich das PW nicht zur Hand habe, aber wenn ich diese Felder nicht ausfülle lassen sich die Einstellungen nicht ändern .... *heul" ....

Noch ein P.S.: kommst du in die Datenbank rein?

eben erst gelesen....  :oops:
Mail zur Not erstmal auf PHP-Mail ändern - dann kommst du erstmal weiter

Das SMTP-PW steht in Reinschrift in deinem Backkup
Wer nicht will, findet Gründe, wer will, findet Wege.

Offline klaumich

  • Posts: 92
  • Gender: Male
  • Ziemlich Ahnungsloser
    • michler-web
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #37 on: September 08, 2016, 03:52:09 PM »
Quote
Noch ein P.S.: kommst du in die Datenbank rein?
Ja komme ich, nur nicht hier am Rechner gerade .....

Das Problem ist, ich kann unter den erweiterten Optionen eintragen was ich möchte
Screenshot http://www.flarakg32.de/temp/Zwischenablage03.jpg

sobald ich speichere ist wieder alles wäch .... obwohl die meldung kommt "Ihre Einstellungen wurden erfogreich und soo ..."
Screenshot http://www.flarakg32.de/temp/Zwischenablage04.jpg
 :-o
Immer in der Hoffnung, dass das Licht am Ende des Tunnels der Ausgang ist ...
[WB vers. 2.12]

Offline klaumich

  • Posts: 92
  • Gender: Male
  • Ziemlich Ahnungsloser
    • michler-web
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #38 on: September 08, 2016, 04:11:33 PM »
Btw, vielleicht kann ein Moderator die Thematik von mir jetzt in einen Extrathread auslagern, weil das ja eigentlich nicht´s mehr mit dem ursächlichen Thema zu tun hat  :oops: Hätte gleich ein Neues erstellen sollen ... sorry
Immer in der Hoffnung, dass das Licht am Ende des Tunnels der Ausgang ist ...
[WB vers. 2.12]

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8391
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #39 on: September 08, 2016, 06:10:35 PM »
Hallo,

Hatte das von dir beschriebene auch bei einem Upgrade. Hab alles mögliche probiert, aber jedesmal, wenn ich die Einstellungen speichern wollte, waren wie von dir beschrieben die geänderten Daten wieder weg.

Da bei mir bei dieser Installation noch keine Seiten angelegt waren, hab ich WB schnell komplett neu installiert. Danach lief dann alles. Das nützt dir aber herzlich wenig.

Hast du die Möglichkeit die setting Tabelle einer funktionierenden SP7 Installation mit der der nicht funktionierenden zu vergleichen? Ich vermute einen Fehler in der Datenbank Struktur dieser Tabelle.

Gruß
Matthiad

Offline klaumich

  • Posts: 92
  • Gender: Male
  • Ziemlich Ahnungsloser
    • michler-web
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #40 on: September 08, 2016, 07:41:57 PM »
Hallo,

Hatte das von dir beschriebene auch bei einem Upgrade. Hab alles mögliche probiert, aber jedesmal, wenn ich die Einstellungen speichern wollte, waren wie von dir beschrieben die geänderten Daten wieder weg.
Genau das Problem habe ich! Hab gerade noch einen Versuch mit den korrekten Maildaten probiert, selber s*** ..... die Änderungen werden nicht gespeichert!

Quote
Hast du die Möglichkeit die setting Tabelle einer funktionierenden SP7 Installation mit der der nicht funktionierenden zu vergleichen? Ich vermute einen Fehler in der Datenbank Struktur dieser Tabelle.
Jupp habe ich, drei Domains laufen schon fehlerfrei mit SP7, jetzt müsste mir nur irgendwer mit einfachen Worten verraten wie ich diesen "Vergleich" anstelle und was ich tun muss  :roll:
Hätte/hab jetzt auch Zugriff auf die Datenbank über MySQL .... wäre very nice wenn sich das Problem irgendwie fixen ließe  8-)

Greez Klaus
Immer in der Hoffnung, dass das Licht am Ende des Tunnels der Ausgang ist ...
[WB vers. 2.12]

Offline jacobi22

  • Posts: 5879
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #41 on: September 08, 2016, 08:18:48 PM »
Ich benutzt PHPmyADmin, ich denk, andere DB-Verwaltungsprogramme sind ähnlich

Variante 1: komplette settings-Tabelle übernehmen

Nimm die Datei aus dem Anhang und entpacke sie Lokal. Öfnne die enthaltene Datei 'wb_settings.sql' mit einem Editor deiner Wahl, z.b. Notepad++

Folgende Anpassungen sind notwendig

Zeile 71 -> ('website_title', 'Dein Titel'), // eventuell anderen Seitentitel eingeben

Zeile 78 -> ('server_email', 'mail@mailserver.com');

Theoretisch sind alle Daten entweder hinterher über die persönlichen Einstellungen oder über die WB-Optionen einstellbar, setze aber bitte mindestens deine Admin-Mailadresse in Zeile 78

Im Anschluß dann in der Datenbankverwaltung zu dieser Settings-Tabelle navigieren, oben auf OPERATIONEN klicken und dann nach Tabelle Leeren (TRUNCATE) suchen. bei mir mittig unten, meißt rot gekennzeichnet.

Nach erfolgreich-Meldung auf IMPORT und angefügte und angepasste Datei auswählen

Variante 2: vergleichen und Korrigieren

Empfehlung: Arbeit mit zwei Browserfenstern nebeneinander, jeweils halb breit. Datenbank 1 im Fenster 1, Datenbank 2 im Fenster zwei
geht auch mit zwei Tabs, dann den zweiten am Reiter mit der Maus aus dem Browser heraus ziehen und fallen lassen.

Nun Punkt für Punkt vergleichen und die notwendigen Korrekturen vornehmen
Wichtig: nicht durcheinander kommen.

Daten wie SMTP würde ich erst über die WB-Optionen eingeben, geht aber mit Copy&Paste auch, wenn es denn die gleichen Daten sind





Wer nicht will, findet Gründe, wer will, findet Wege.

Offline Hollol

  • Posts: 204
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #42 on: September 08, 2016, 08:32:54 PM »
'n Abend zusammen,

bei mir das gleiche Problem von 2.8.2 -> 2.8.3 (Rev 1611) -> 2.8.3 +SP7
Fehlermeldung beim Upgrade-Script wie oben.
Beim zweiten Durchlauf zeigte es OK.

In den Optionen:

Servereinstellungen:
Medienverzeichnis: MEDIA_DIRECTORY,

Maileinstellungen:
Standard "VON" Adresse: SERVER_EMAIL


Was mir aufgefallen ist:
Die "Settings-Table" in der Datenbank hat nur 48 Datensätze. In anderen SP7-Sites sind es 65 Datensätze!

Die Datensätze zur Media-Directory und die Server-Mail fehlen komplett, so dass man sie nicht einmal manuell nachtragen könnte.

Gruß
Hollol

Edit: werd auch mal den Tipp von jacobi ausprobieren. Hört sich gut an.
« Last Edit: September 08, 2016, 08:42:38 PM by Hollol »

Offline Hollol

  • Posts: 204
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #43 on: September 08, 2016, 09:23:55 PM »
Hab jetzt mal meine Settings-Table (Stand: "nach" dem Upgrade 2.8.2 -> 2.8.3 -> 2.8.2+SP7) mit der von jacobi vergleichen.

Folgende Datensätze fehlen in meiner SQL-Datei komplett:

('media_directory', '/media'),
('operating_system', 'linux'),
('secure_form_module', ''),
('server_email', 'mail@mailserver.com');
('string_dir_mode', '0777'),
('string_file_mode', '0666'),
('wbmailer_default_se ndername', 'WB Mailer'),
('wbmailer_routine', 'phpmail'),
('wbmailer_smtp_auth', '1'),
('wbmailer_smtp_host', ''),
('wbmailer_smtp_passw ord', ''),
('wbmailer_smtp_usern ame', ''),

Falls das irgendwie weiter hilft.

Gruß
Hollol
« Last Edit: September 08, 2016, 09:30:12 PM by Hollol »

Offline klaumich

  • Posts: 92
  • Gender: Male
  • Ziemlich Ahnungsloser
    • michler-web
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #44 on: September 08, 2016, 09:42:14 PM »
Ich benutzt PHPmyADmin, ich denk, andere DB-Verwaltungsprogramme sind ähnlich
Nutze ich auch, über Parallels PleskPanel

Quote
Im Anschluß dann in der Datenbankverwaltung zu dieser Settings-Tabelle navigieren, oben auf OPERATIONEN klicken und dann nach Tabelle Leeren (TRUNCATE) suchen. bei mir mittig unten, meißt rot gekennzeichnet.
Hab jetzt mal meine Settings-Table (Stand: "nach" dem Upgrade 2.8.2 -> 2.8.3 -> 2.8.2+SP7) mit der von jacobi vergleichen.

Folgende Datensätze fehlen in meiner SQL-Datei komplett:

('media_directory', '/media'),
('operating_system', 'linux'),
('secure_form_module', ''),
('server_email', 'mail@mailserver.com');
('string_dir_mode', '0777'),
('string_file_mode', '0666'),
('wbmailer_default_se ndername', 'WB Mailer'),
('wbmailer_routine', 'phpmail'),
('wbmailer_smtp_auth', '1'),
('wbmailer_smtp_host', ''),
('wbmailer_smtp_passw ord', ''),
('wbmailer_smtp_usern ame', ''),
Ich glaube mal mein Problem ist weitaus problematischer ......... ich habe garkeine "wb_settings" Tabelle in meiner Datenbank  :cry:

folgende Tabellen stehen in der DB:
*********************************
exp_access
exp_config
exp_counted_users
exp_data
exp_downloads_and_h yperlinks
exp_downloads_and_h yperlinks_logs
exp_ignored_users
exp_locale_informat ion
exp_log_data
exp_online_users
exp_pages
exp_referrers
exp_screen_resoluti ons
exp_search_engines
exp_user_agents
groups
mod_addon_file_edit or
mod_calendar
mod_calendar_action s
mod_calendar_settin gs
mod_captcha_control
mod_code
mod_droplets
mod_flickrgallery
mod_foldergallery_c ategories
mod_foldergallery_f iles
mod_foldergallery_s ettings
mod_form_fields
mod_form_settings
mod_form_submission s
mod_gallery_images
mod_gallery_setting s
mod_gdpics_captions
mod_gdpics_settings
mod_guestbook
mod_guestbook_setti ngs
mod_jsadmin
mod_menu_link
mod_news_comments
mod_news_groups
mod_news_posts
mod_news_settings
mod_output_filter
mod_procalendar_act ions
mod_procalendar_eve ntgroups
mod_procalendar_set tings
mod_sitemap
mod_videogal_settin gs
mod_wrapper
mod_wysiwyg
pages
search
sections
settings
users
*********************************
Wenn ich in die DB einer bereits upgedateten Domain schaue ist Selbige da  :-(

DB:
*********************************
wb_addons
wb_groups
wb_mod_addon_file_e ditor
wb_mod_captcha_cont rol
wb_mod_code
wb_mod_droplets
wb_mod_flickrgaller y
wb_mod_form_fields
wb_mod_form_setting s
wb_mod_form_submiss ions
wb_mod_jsadmin
wb_mod_menu_link
wb_mod_news_comment s
wb_mod_news_groups
wb_mod_news_posts
wb_mod_news_setting s
wb_mod_output_filte r
wb_mod_wrapper
wb_mod_wysiwyg
wb_pages
wb_search
wb_sections
wb_settings
wb_users
**************************

ich hab so das ganz üble Gefühl das da was ziemlich schief gelaufen ist  :cry: :cry:
Immer in der Hoffnung, dass das Licht am Ende des Tunnels der Ausgang ist ...
[WB vers. 2.12]

Offline Hollol

  • Posts: 204
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #45 on: September 08, 2016, 09:47:39 PM »

sections
settings <=
users
**************************
Wenn ich in die DB einer bereits upgedateten Domain schaue ist Selbige da  :-(

Da ist sie doch  :wink:
Du hast nur keinen Präfix vor den Tabellen stehen. Wahrscheinlich bei der Installation das WB_ gelöscht.


Edit: in meiner Backup-SQL-Datei von der 2.8.2 Installation sind die o.g. Datensätze alle da, die jetzt fehlen.
Sieht so aus, als würden die beim Durchlauf mit dem Upgrade-Script gelöscht werden.
Versteh ich nicht, da man ja vorher auf 2.8.3 Rev 1611 updated?!

Gruß
Hollol
« Last Edit: September 08, 2016, 09:55:41 PM by Hollol »

Offline klaumich

  • Posts: 92
  • Gender: Male
  • Ziemlich Ahnungsloser
    • michler-web
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #46 on: September 08, 2016, 10:09:37 PM »
Okee .. hab gerade mal die Domain gecheckt die ich auch von Ver. 2.8.1 über 2.8.3 auf 2.8.3 SP7 geupdatet habe, da ist die Tabellenstrucktur wie in der "Problemdomain", also heist dort die entsprechende Tabelle "settings" schätze ich!
Allerdings fehlen da bei mir auch ne Latte an Angaben ......

Die funktionierende settings-table hat 60 Datensätze, die andere nur 48  :-(
Immer in der Hoffnung, dass das Licht am Ende des Tunnels der Ausgang ist ...
[WB vers. 2.12]

Offline klaumich

  • Posts: 92
  • Gender: Male
  • Ziemlich Ahnungsloser
    • michler-web
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #47 on: September 08, 2016, 10:21:16 PM »

sections
settings <=
users
**************************
Wenn ich in die DB einer bereits upgedateten Domain schaue ist Selbige da  :-(

Da ist sie doch  :wink:
Du hast nur keinen Präfix vor den Tabellen stehen. Wahrscheinlich bei der Installation das WB_ gelöscht.
Jupp das hab ich geschnallt  :lol:

Quote
Edit: in meiner Backup-SQL-Datei von der 2.8.2 Installation sind die o.g. Datensätze alle da, die jetzt fehlen.
Ich hab auch ein Backup der DB nur wie gugg ich da rein  :-o OMG da war wieder mein Prob mit dem Wald .... mit der MySql Version von XAMPP kann ich das Backup nicht improtieren, File zu groß heist es da ......  :|
Immer in der Hoffnung, dass das Licht am Ende des Tunnels der Ausgang ist ...
[WB vers. 2.12]

Offline klaumich

  • Posts: 92
  • Gender: Male
  • Ziemlich Ahnungsloser
    • michler-web
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #48 on: September 08, 2016, 10:40:13 PM »
Soo ich hab jetzt mal die funktionelle Settingstabelle und die "verhunzte" als CSV exportiert und in Excel nebeneinander gefügt .... (s.Anhang)

Es fehlen wie bei Hollol:
*************************************
media_directory
operating_system
string_file_mode
string_dir_mode
wbmailer_routine
server_email
wbmailer_default_se ndername
wbmailer_smtp_host
wbmailer_smtp_auth
wbmailer_smtp_usern ame
wbmailer_smtp_passw ord

fingerprint_with_ip _octets
secure_form_module

*************************************
komplett, dafür ist aber 1 Parameter vorhanden der in der Funktionierenden fehlen

warn_page_leave

wenn ich jetzt die fehlenden Parameter in der Tabelle der Datenbank ergänze in MySql Admin, funzt das dann ????
Sorry das ich Euch hier so zutexte ....
« Last Edit: September 08, 2016, 10:45:52 PM by klaumich »
Immer in der Hoffnung, dass das Licht am Ende des Tunnels der Ausgang ist ...
[WB vers. 2.12]

Offline jacobi22

  • Posts: 5879
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Update Anleitung von 2.8.3-SP6 auf 2.8.3-SP7
« Reply #49 on: September 08, 2016, 10:45:00 PM »
Du kannst in der php.ini in Xampp die Werte hochsetzen. am einfachsten in der Kontrollpanel bei Apache auf Konfiguration und dort auf php.ini

Suche in der sich öffnenden Datei nach post_max_size  und nach upload_max_filesize
Setze beide Werte auf mindestens 8M, bleibst du lokal, dann ruhig auch auf 50M oder mehr

Danach Apache stoppen und wieder starten

P.S. dort kann man auch ZIP- oder GZ-Dateien hochladen
Wer nicht will, findet Gründe, wer will, findet Wege.