Author Topic: Cart Error after WB Upgrade  (Read 2670 times)

daydreamer

  • Guest
Cart Error after WB Upgrade
« on: August 29, 2014, 04:21:45 PM »
I have upgraded WB to 2.8.3 sp3 and when item is added to cart or view checkout get this error

Code: [Select]
Warning: mysql_insert_id(): Access denied for user 'user'@'localhost' (using password: NO) in /home/site/public_html/modules/bakery/view.php on line 187

Warning: mysql_insert_id(): A link to the server could not be established in /home/site/public_html/modules/bakery/view.php on line 187

Line 187 in view.php is
Code: [Select]
$order_id = mysql_insert_id();
Anyone else have this issue?

Offline Gast

  • Posts: 5920
Re: Cart Error after WB Upgrade
« Reply #1 on: August 29, 2014, 08:00:39 PM »
i think, the same problem like the most ohters in the last days

change
Code: [Select]
$order_id = mysql_insert_id(); to
Code: [Select]
$order_id = $database->getLastInsertId();
it's possible, that you found more errors on other placed in this or other modules

daydreamer

  • Guest
Re: Cart Error after WB Upgrade
« Reply #2 on: August 29, 2014, 08:07:54 PM »
Thanks that's fixed the issue  :-D

 

postern-length