Author Topic: 2.8.1 Fehler im Newsmodul: nachträgliche Gruppenzuordnung von Newsbeiträgen  (Read 1304 times)

Offline pfreud01

  • Posts: 62
  • Gender: Male
servus gemeinde,

eigentlich hatte ich vor, meine zahlreichen newsbeiträge nachträglich in gruppen einzuordnen und auf verschiedenen unterseiten mit anynews gruppenbasiert auszugeben. da anynews zu cwsoft-anynews mutierte und 2.8.3 benötigt, wollte ich eigentlich erst von 2.8.1. auf 2.8.3 updaten und dann meine seiten umbauen, aber genau da kam mir der serverausfall in die quere. also beschloss ich, die geplanten änderungen auf meiner seite zunächst ohne update durchzuziehen.

ich legte also die benötigten gruppen im newsmodul an und ordnete von nun an die neuen news problemlos passend zu. tage später wollte ich auch die vorher angelegten news den gruppen zuordnen, aber erhielt prompt eine fehlermeldung (irgendetwas in /pages scheitert). gleichzeitig war meine komplette homepage nicht mehr erreichbar: fehler 404 - dateien nicht zu finden! da dämmerte mir, dass die fehlermeldung vom Newsmodul was von /pages faselte, wo ich doch sämtliche seiten im ordner /inhalte hatte, also schaute ich bei optionen nach und merkte, dass meine änderungen (seitenverzeichnis) leer waren. ich gab sie nochmals richtig ein, darauf erhielt ich überall den fehler 403 - zugriff verweigert, nur die news-seite war normal erreichbar.

es war mir zu blöd, den genauen grund für den fehler zu finden. ich habe nun begonnen, die seite komplett neu auf 2.8.3 aufzubauen. da ich glücklicherweise das alte backend noch voll erreichen kann (nur das frontend spinnt), kopiere ich halt die inhalte sukkzessiv herüber. ob sich 2.8.3 im newsmodul ebenso verhält, will ich nicht testen, ich habe vorsorglich alle newsgruppen vorher angelegt...

noch fragen?
gruß, pfreud01
« Last Edit: March 31, 2013, 09:53:06 PM by pfreud01 »

Offline cwsoft

  • Posts: 605
Hi,

da anynews zu cwsoft-anynews mutierte und 2.8.3 benötigt
cwsoft-anynews setzt WB 2.8.2 oder höher voraus, würde generell (abgesehen von den jQuery Slidern) aber auch ab 2.8.0 laufen.

Gruss
« Last Edit: March 29, 2013, 10:41:36 PM by cwsoft »

Offline pfreud01

  • Posts: 62
  • Gender: Male
danke, cwsoft.

wollte es jedenfalls auf die 2.8.1 installieren, hat sich aber beschwert. jetzt bei 2.8.3 flutscht es (und ich liebe es!).

gruß, pfreud01

Offline cwsoft

  • Posts: 605
Hi,

Quote
wollte es jedenfalls auf die 2.8.1 installieren, hat sich aber beschwert. jetzt bei 2.8.3 flutscht es
Die Mindestvoraussetzun g wurde auf WB 2.8.2 gesetzt, da erst mit dieser Version eine halbwegs stabile und brauchbare Einbindung von jQuery im Core implementiert wurde und die jQuery Einbindung von WB 2.8.0 bis 2.8.2 mehrmals überarbeitet wurde.

Will mann die in cwsoft-anynews mitgelieferten jQuery Slider eh nicht benutzen, kann man die im Modul enthaltene Datei precheck.php umbenennen, oder die Zeile 32 anpassen, um das Modul auch mit älteren WB Versionen zu betreiben.

Gruss

« Last Edit: April 01, 2013, 08:48:05 AM by cwsoft »

Offline pfreud01

  • Posts: 62
  • Gender: Male
danke. jedenfalls war die verwendung von cwsoft-anynews der grund, warum ich nun 2.8.3 verwende. dass diese allgemein besser flutscht als die 2.8.1, ist mir recht.  :-D

Offline cwsoft

  • Posts: 605
danke. jedenfalls war die verwendung von cwsoft-anynews der grund, warum ich nun 2.8.3 verwende
Wenn mein Modul dazu beiträgt Anwender zu einem WB-Upgrade zu bewegen, lasse ich die Versionsprüfung drinn :wink:

 

postern-length