Author Topic: Can anyone upgrade CKeditor?  (Read 112868 times)

Offline nibz

  • Posts: 683
  • Gender: Male
Re: Can anyone upgrade CKeditor?
« Reply #75 on: October 17, 2013, 03:36:53 PM »
Thanks Marmot! Hope the Module Repo will be updated with this one.
Hans

I updated the repo with the new version.
Thanks to marmot for updating the file :)

jacobi22

  • Guest
Re: Can anyone upgrade CKeditor?
« Reply #76 on: October 17, 2013, 07:27:04 PM »
one (big) problem with the Vers 4.2.1 131001, but only on my locale testarea (it works fine, if i use the CKEditor on my Webspace)

i try it in english..
if i change the Wysiwyg-Editor in Advanced Settings from FCK to CKEditor, i can work with the CKEditor, no problems, everything works
if i close the browser, clean the cache and start again, it looks like a deinstalled Wysiwyg-Editor, only a textarea with the source code from this section

i try it with Firefox 25, IE 10 and Chrome, the same problem in all browsers

if i look into the source code from the backend page, i found this


Code: [Select]
<script type="text/javascript">//<![CDATA[
window.CKEDITOR_BASEPATH='G:/cms/wb_test_1930/modules/ckeditor/ckeditor/';
//]]></script>
<script type="text/javascript" src="G:/cms/wb_test_1930/modules/ckeditor/ckeditor/ckeditor.js?t=B8DJ5M3"></script>

is it possible, that i have a locale problem with the CKEDITOR_BASEPATH?

WB_URL for this project is http://cms/wb_test_1930/


cleared with the update to the next version
« Last Edit: November 23, 2013, 03:57:49 PM by jacobi22 »

Offline marmot

  • Posts: 1103
Re: Can anyone upgrade CKeditor?
« Reply #77 on: October 24, 2013, 11:00:37 PM »
Hi,

Quote from: info.php
*  version 4.2.2 131024
 *  + using cke 4.2.2 full
 *  ! updated moonocolor skin to v 1.1 (1.2 didn't work for some reasons)

regards

Edith: new version below
« Last Edit: November 21, 2013, 09:10:16 PM by marmot »

jacobi22

  • Guest
Re: Can anyone upgrade CKeditor?
« Reply #78 on: October 24, 2013, 11:44:03 PM »
Works very good for me, no problems - THANKS again

P.S.: for the next version - i found some write errors in

ckeditor/ckeditor/plugins/codemirror/lang/de.js

Auskommentierung entferen -> Auskommentierung entfernen

ckeditor/ckeditor/lang/de.js  (in the first lines)

Alle nicht gespeicherten Änderungen gehen verlohren -> Alle nicht gespeicherten Änderungen gehen verloren

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8391
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Can anyone upgrade CKeditor?
« Reply #79 on: October 25, 2013, 06:51:19 AM »
Hallo,

nachdem ich ja seit kurzer Zeit auch ein Freund des CKEditor bin, auch von meiner Seite Daumen hoch. Scheint alles zu funktionieren (hab aber auch noch nicht alles gestestet).

Auf jeden Fall mal vielen Dank an marmot für die tolle Arbeit.

Gruß
Matthias

Offline nibz

  • Posts: 683
  • Gender: Male
Re: Can anyone upgrade CKeditor?
« Reply #80 on: October 25, 2013, 06:09:45 PM »
Hi,

Quote from: info.php
*  version 4.2.2 131024
 *  + using cke 4.2.2 full
 *  ! updated moonocolor skin to v 1.1 (1.2 didn't work for some reasons)

regards

Thanks for the great work Marmot!
I updated the module repo again! :)

Offline marmot

  • Posts: 1103
Re: Can anyone upgrade CKeditor?
« Reply #81 on: November 21, 2013, 09:09:33 PM »
Hi,

here we go....

Quote
*  version 4.3.0 131120
 *  + using cke 4.3.0 full
 *  ! wblink plugin can address news page without selecting a news item
 *  ! fixed problem in wb droplets plugin

regards

Edith: find updated version below
« Last Edit: December 12, 2013, 09:03:17 PM by marmot »

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8391
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Can anyone upgrade CKeditor?
« Reply #82 on: November 23, 2013, 11:28:37 AM »
Hello marmot,

great work. I love CKEditor more and more. Works without any problems.

Matthias

Offline N1kko

  • Posts: 137
  • Gender: Male
Re: Can anyone upgrade CKeditor?
« Reply #83 on: November 23, 2013, 03:49:15 PM »
Thanks marmot  :-D
My Tools: MacBook Pro Retina, Coda2, Sketch 3... Couldn't live without them

Offline nibz

  • Posts: 683
  • Gender: Male
Re: Can anyone upgrade CKeditor?
« Reply #84 on: December 02, 2013, 12:10:35 AM »
Hi,

here we go....

Quote
*  version 4.3.0 131120
 *  + using cke 4.3.0 full
 *  ! wblink plugin can address news page without selecting a news item
 *  ! fixed problem in wb droplets plugin

regards

Updated the addons repo

Offline Yetiie

  • Posts: 778
Re: Can anyone upgrade CKeditor?
« Reply #85 on: December 03, 2013, 10:14:17 AM »
Thx for updating the CKE and uploading it to the respository too.
Great Job :-)

Offline Argos

  • Posts: 2542
  • Gender: Male
    • Argos Media
Re: Can anyone upgrade CKeditor?
« Reply #86 on: December 03, 2013, 01:55:50 PM »
I tried the 4.30 version and it seems that the link insert function fails. When I click on the icon to insert a link, the screen goes transparent white, like the background for a lightbox, but that's all. No lightbox or popup appears, and actually WB freezes. You have to remove the last part of the url to access the admin again.

Can anyone confirm this? I tried the latest versions of IE, Chrome and Firefox. I must admit I run WP 2.8.1 on that site, so maybe it works on WB 2.8.3. I will try that on another site. But 2.8.1 is not really obsolete or something, so you would expect it to work fine.

===========

OK, I tried it on 2.8.3 as well. Now the popup appears, but it doesn't work in IE11. Firefox and Chrome are allright, but in IE11 the buttons are not working, and also the hidden, dynamic parts of the popup are visible. So you see the insert email link part of the popup right away, even if you don't choose to do so.

So all in all, the module is rather picky right now.
« Last Edit: December 03, 2013, 02:10:06 PM by Argos »
Jurgen Nijhuis
Argos Media
Heiloo, The Netherlands
----------------------------------------------------------------
Please don't request personal support, use the forums!

jacobi22

  • Guest
Re: Can anyone upgrade CKeditor?
« Reply #87 on: December 05, 2013, 08:35:22 PM »
extension for internal links to bakery-product-pages in the (wb)Link-dialog of ckeditor Vers 4.30 from marmot
(build a list with all product- or item-pages from the bakery-shop, if you select "wblink" in the link-dialog)
works in ckeditor 4.3 for news- and topic-pages

File: modules/ckeditor/ckeditor/plugins/wblink/pages.php

change this line
Code: [Select]
echo $NewsItemsSelectBox;
with this code
Code: [Select]
//Bakery_Items
$bakerySections = $database->query("SELECT * FROM ".TABLE_PREFIX."sections WHERE module = 'bakery'");
while($section = $bakerySections->fetchRow()){
        $bakery = $database->query("SELECT title, link FROM ".TABLE_PREFIX."mod_bakery_items WHERE active=1 AND section_id = ".$section['section_id']);
        $NewsItemsSelectBox .= "NewsItemsSelectBox[".$section['page_id']."] = new Array();";
        while($item = $bakery->fetchRow()) {
                $NewsItemsSelectBox .= "NewsItemsSelectBox[".$section['page_id']."][NewsItemsSelectBox[".$section['page_id']."].length] = new Array('".$item['title']."', '".WB_URL.PAGES_DIRECTORY.$item['link'].PAGE_EXTENSION."');";
        }
}

echo $NewsItemsSelectBox;

for use in Link-dialog

choose WB-Link in Link-Type
choose your Bakery-Main-Page (Overview) in WB-Page
select your item in NEWS-Item

Offline marmot

  • Posts: 1103
Re: Can anyone upgrade CKeditor?
« Reply #88 on: December 12, 2013, 09:02:15 PM »
Hi,

Can anyone confirm this? I tried the latest versions of IE, Chrome and Firefox. I must admit I run WP 2.8.1 on that site, so maybe it works on WB 2.8.3. I will try that on another site. But 2.8.1 is not really obsolete or something, so you would expect it to work fine.
can't confirm. It seems WB team doesn't even support version 283 anymore. As an experienced user you surely read the modules deails where you can find that this module is designed for wb 283. Nevertheless I tried it on wb281 for you and it worked without issues.
Quote
OK, I tried it on 2.8.3 as well. Now the popup appears, but it doesn't work in IE11. Firefox and Chrome are allright, but in IE11 the buttons are not working, and also the hidden, dynamic parts of the popup are visible. So you see the insert email link part of the popup right away, even if you don't choose to do so.
can't confirm, maybe some browser cache stuff. But maybe the new version works better for you. On the other hand just wait for the much better version of this module patched by the wb team which surerly is perfect just like wb284 for which the new version is designed.
Quote
So all in all, the module is rather picky right now.
sometimes I can't help but to think some forum users are so too ;)

Quote from: info.php
*  version 4.3.1 131211
 *  + using cke 4.3.1 full
 *  ! again fixed problem in wb droplets plugin
 *  ! fixed problem in wb link plugin
 *  + bakery items are selectable as wb link, thanks to jacoby22: http://www.WebsiteBaker.org/forum/index.php/topic,25334.msg181817.html#msg181817
 *   ! wb link plugin: items select is only shown when a news, topis or bakery page is selected

regards

Edith: find latest version below
« Last Edit: December 19, 2013, 08:12:07 PM by marmot »

Offline Argos

  • Posts: 2542
  • Gender: Male
    • Argos Media
Re: Can anyone upgrade CKeditor?
« Reply #89 on: December 15, 2013, 12:10:11 AM »
Hm.. doesn't work either. I do get a popup now, but it doesn't create links. The droplet function doesn't work either, nor does other settings. I tried several WB 283 installs, but CKE fails on all installs somehow. Maybe it has something to do with some server setting, I don't know.
Jurgen Nijhuis
Argos Media
Heiloo, The Netherlands
----------------------------------------------------------------
Please don't request personal support, use the forums!

Offline marmot

  • Posts: 1103
Re: Can anyone upgrade CKeditor?
« Reply #90 on: December 15, 2013, 10:22:27 AM »
Hi,

Maybe it has something to do with some server setting, I don't know.
I don't know too. Surely I'm interested in solving this issue but to find out what is going on I would need an admin and ftp account on one of your (test) sites.

regards

jacobi22

  • Guest
Re: Can anyone upgrade CKeditor?
« Reply #91 on: December 15, 2013, 10:39:53 AM »
i found a message in another thread, that some people has problems with the cke 4.x in older jquery-versions. can that be the problem?

Offline Argos

  • Posts: 2542
  • Gender: Male
    • Argos Media
Re: Can anyone upgrade CKeditor?
« Reply #92 on: December 16, 2013, 12:24:08 PM »
Yes, that could be. I will check that out. This weekend I found that the latest module works fine on a WB 2.8.1 install. So the must be some conflict somewhere, and that could very well be a jquery one.
Jurgen Nijhuis
Argos Media
Heiloo, The Netherlands
----------------------------------------------------------------
Please don't request personal support, use the forums!

Offline nibz

  • Posts: 683
  • Gender: Male
Re: Can anyone upgrade CKeditor?
« Reply #93 on: December 17, 2013, 09:25:54 PM »

Quote from: info.php
*  version 4.3.1 131211
 *  + using cke 4.3.1 full
 *  ! again fixed problem in wb droplets plugin
 *  ! fixed problem in wb link plugin
 *  + bakery items are selectable as wb link, thanks to jacoby22: http://www.WebsiteBaker.org/forum/index.php/topic,25334.msg181817.html#msg181817
 *   ! wb link plugin: items select is only shown when a news, topis or bakery page is selected


Updated the addonsrepo with this file :)

Offline marmot

  • Posts: 1103
Re: Can anyone upgrade CKeditor?
« Reply #94 on: December 19, 2013, 08:09:53 PM »
Hi,

Quote from: info.php
*  version 4.3.1.1 131219
 *  ! editor was not attached to textarea named "description", reported by bsdzilla: http://www.WebsiteBaker.org/forum/index.php/topic,17913.msg182267.html#msg182267

regards

Edith: find update below
« Last Edit: January 10, 2014, 10:35:40 PM by marmot »

Offline Argos

  • Posts: 2542
  • Gender: Male
    • Argos Media
Re: Can anyone upgrade CKeditor?
« Reply #95 on: January 07, 2014, 07:29:01 PM »
The "browse on server" function (images, files) doesn't work out of the box.
Jurgen Nijhuis
Argos Media
Heiloo, The Netherlands
----------------------------------------------------------------
Please don't request personal support, use the forums!

Offline cwsoft

  • Posts: 605
Re: Can anyone upgrade CKeditor?
« Reply #96 on: January 07, 2014, 08:45:25 PM »
Hi,

Quote from: argos
The "browse on server" function (images, files) doesn't work out of the box.
Maybe this has to do with an error in the media handling of latest WB 2.8.4 REV 2082.

Just tried a clean install on Windows testserver with PHP 5.4.19 and Firefox 26.0, but I can't upload images like jpg from the WB 2.8.4 media folder at all. Always got the error message file already exists (but there is no file available). Activating the "overwrite file during upload" doesn't work either.

False positive: For details read this post

The "browse on server" feature works out of the box with Marmots CKEditor version v4.3.1.1 below including image upload etc. Tested on Windows server with PHP 5.4.19, WB 2.8.4 REV 2082 and Firefox 26 - both admin themes.

Cheers cwsoft
« Last Edit: January 07, 2014, 11:13:12 PM by cwsoft »

Offline marmot

  • Posts: 1103
Re: Can anyone upgrade CKeditor?
« Reply #97 on: January 07, 2014, 09:45:52 PM »
Hi,

The "browse on server" function (images, files) doesn't work out of the box.
you already reported somthing like this here. I tried to fix. You confirmed it works. Maybe this is a cache problem again?
Once again I offer you to have a look at it if you grant me ftp and admin rights for a (test) installation as I can't confirm this problem.
Maybe this has to do with an error in the media handling of latest WB 2.8.4 REV 2082.
maybe cwsoft is right if you are using wb 2.8.4

regards

Eidth: ok now I can confirm for IE 11
« Last Edit: January 07, 2014, 10:19:21 PM by marmot »

Offline Argos

  • Posts: 2542
  • Gender: Male
    • Argos Media
Re: Can anyone upgrade CKeditor?
« Reply #98 on: January 07, 2014, 11:42:10 PM »
I forgot to tell: my report was based on a clean WB 2.8.4 with the clean CKE from above. So everything default and new.
Jurgen Nijhuis
Argos Media
Heiloo, The Netherlands
----------------------------------------------------------------
Please don't request personal support, use the forums!

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8391
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Can anyone upgrade CKeditor?
« Reply #99 on: January 08, 2014, 06:27:09 AM »
Hello,

WB 2.8.4 trys to set the backend in IE9 compatible Modus. Look at Rev. 2006. There is a:

Code: [Select]
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE9" />
in:
admin/skel/themes/htt/loginBox.htt
admin/skel/themes/htt/loginForgot.htt
admin/skel/themes/htt/maintenance.htt
templates/wb_theme/templates/header.htt

This is not needed for CKEditor, so i removed it and got CKEditor running without error messages.

Matthias
« Last Edit: January 08, 2014, 08:19:24 AM by ruebenwurzel »

 

postern-length