Author Topic: WB-Forum 0.3 -> WB-Forum 0.5  (Read 30034 times)

Offline dbs

  • Betatester
  • **
  • Posts: 8076
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #75 on: July 09, 2012, 07:58:47 PM »
Hm, verstehe. Erstmal ohne Lösung, aber ich versuche was.

Offline dbs

  • Betatester
  • **
  • Posts: 8076
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #76 on: July 09, 2012, 10:39:44 PM »
Probiere mal das,
allerdings bekomme ich den Usernamen noch nicht mit rein,
weil da erst user_id mit username in verbindung gebracht werden muss.

Code: [Select]
if ( !isset($max) ){    $max = 10;    }
if ( !isset($order) ){    $order= "DESC";    }
global $database, $wb;
$mod_query = $database->query("SELECT * FROM ".TABLE_PREFIX.
"mod_forum_post ORDER BY postid ".$order." LIMIT ".$max);

$quote = '';
// BBCode to find...
$in = array(
'/\[b\](.*?)\[\/b\]/ms',
'/\[i\](.*?)\[\/i\]/ms',
'/\[u\](.*?)\[\/u\]/ms',
'/\[s\](.*?)\[\/s\]/ms',
'/\[url\="?(.*?)"?\](.*?)\[\/url\]/ms',
'/\[size\="?(.*?)"?\](.*?)\[\/size\]/ms',
'/\[color\="?(.*?)"?\](.*?)\[\/color\]/ms',
'/\[quote](.*?)\[\/quote\]/ms'
);
// And replace them by...
$out = array(
'<strong>\1</strong>',
'<em>\1</em>',
'<u>\1</u>',
'<strike>\1</strike>',
'<a href="\1">\2</a>',
'<span style="font-size: \1%;">\2</span>',
'<span style="color: \1;">\2</span>',
'<fieldset style="background-color: #EEE; padding: 0 4px 2px; font-style: italic;"><legend>'.$quote.'</legend>\1</fieldset>'
);


$mod_list = '<div id="last-forum-posts">';
while ( $row = $mod_query->fetchRow()){

 $date = date('d.m.Y', $row['dateline']);
 $text = preg_replace($in, $out, $row['text']);

 $mod_list .= '<div class="lfp-date">'.$date.'</div>';
 $mod_list .= ' <a class="lfp-link" href="'.WB_URL.'/modules/forum/thread_view.php?sid='.$row["section_id"].'&pid='.$row["page_id"].'&tid='.$row["threadid"].'">'.$row["title"].'</a><br>';
 $mod_list .= '<div class="lfp-text">'.$text.'</div><br />';
}
$mod_list .= '</div>';
return $mod_list;

Offline iradj

  • Posts: 353
  • Gender: Male
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #77 on: July 09, 2012, 11:33:01 PM »
Dieses Problem ist gelöst. Siehe Bild

Iradj

fischstäbchenbrenner

  • Guest
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #78 on: July 10, 2012, 11:08:23 AM »
Wo ist das Modul denn jetzt eigentlich zum downloaden?
Ich kenn mich nicht mehr aus..

Offline iradj

  • Posts: 353
  • Gender: Male

fischstäbchenbrenner

  • Guest
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #80 on: July 10, 2012, 11:55:35 AM »
Danke - habs gerade mal installiert.
Hmm... ich steh wie der Ochs vorm Tor:
Außer den Überschriften sehe ich _nichts_. :?

Offline dbs

  • Betatester
  • **
  • Posts: 8076
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #81 on: July 10, 2012, 06:33:14 PM »
Forum anlegen, Unterforum anlegen, dann müsste es losgehen mit dem Forum.

fischstäbchenbrenner

  • Guest
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #82 on: July 10, 2012, 07:40:42 PM »
Ahhh!
Vielleicht sollte man das irgendwo erwähnen: Man muss ein Unterforum anlegen.. von selbst würde man da nicht drauf kommen.

Offline iradj

  • Posts: 353
  • Gender: Male
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #83 on: July 10, 2012, 09:45:00 PM »
Hallo dbs,

ich komme wieder mit einen sondern Wünsch!! Wenn die einzelne Forumbeitäge zu lang sind wird 10 letzte Beiträge nicht so gut aussehen. Ich denke daran, das man die Beiträge die mit droplet ruft jeweils auf maximal 5-10 Zeilen begrenzt.
Ist es zu weit her geholt?

Grüße Iradj

Offline dbs

  • Betatester
  • **
  • Posts: 8076
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #84 on: July 11, 2012, 07:11:07 PM »
Du hast schon recht, man sollte es begrenzen.
Mit PHP geht das sicher, aber ich würde erstmal mit CSS probieren.
Der Text hat ein eigenes Div mit class lfp-text, gib ihm mal ein paar Werte.

Code: [Select]
.lfp-text { height: 50px; overflow: hidden; }
« Last Edit: July 11, 2012, 10:44:23 PM by dbs »

Offline iradj

  • Posts: 353
  • Gender: Male
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #85 on: July 11, 2012, 10:37:44 PM »
Vielen Dank, so ist auch recht. Ich werde es versuchen und das Ergebnis bekannt geben.

Offline dbs

  • Betatester
  • **
  • Posts: 8076
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #86 on: July 12, 2012, 07:37:11 PM »
besser noch ist
Code: [Select]
.lfp-text {max-height: 50px; overflow: hidden;}

Offline iradj

  • Posts: 353
  • Gender: Male
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #87 on: July 18, 2012, 01:57:51 PM »
Bin par Tage weg gewesen!

Ich habe die werte für div in frontend.css des Forums  eingegeben und es funktioniert einwandfrei.

Viele Grüße Iradj

Offline dbs

  • Betatester
  • **
  • Posts: 8076
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #88 on: August 03, 2012, 11:52:10 PM »
Hello,

kann es sein, dass der Antworten-Counter macht was er will?
Habe in einem Thread viele Antworten gelöscht, übrig blieben 5, der Counter zeigt aber 25.

Gruß
dbs

Offline marmot

  • Posts: 1103
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #89 on: August 05, 2012, 11:37:25 AM »
Hi,

kann es sein, dass der Antworten-Counter macht was er will?
Habe in einem Thread viele Antworten gelöscht, übrig blieben 5, der Counter zeigt aber 25.
kann ich so nicht nachvollziehen. Kannst du es reproduzieren? Wenn ja, unter welchen Bedingungen?
Da sieht man übrigens mal wieder, dass sich Zensur auf Dauer einfach nicht auszahlt  :-D.

Gruß

Offline dbs

  • Betatester
  • **
  • Posts: 8076
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #90 on: August 05, 2012, 11:53:40 AM »
Waren alles Testeinträge auf dem Weg von 0.3 zu 0.5.  :wink:
Guckst du
Scheinbar zählt er auch rückwärts, aber es passt nicht zum SOLL-Zustand.
« Last Edit: August 05, 2012, 11:56:56 AM by dbs »

Offline marmot

  • Posts: 1103
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #91 on: August 05, 2012, 09:26:15 PM »
Hi,

Guckst du
Scheinbar zählt er auch rückwärts, aber es passt nicht zum SOLL-Zustand.
nun, dass es einmal so aufgetreten ist, glaube ich schon. Wer weiß was da alles zwischendurch passiert ist, durch die updates und sonstige Experimente.
Ich kann ja keine Beiträge bei dir löschen und somit ja auch nichts probieren.
Es scheint ja nur das erste Thema betroffen zu sein, der Rest stimmt.
Wie gesagt, es müßte halt irgendwie reproduzierbar sein. Ich habe mal schnell den entsprechenden Code überflogen, aber nichts besonderes entdeckt.
Ich habe lokal versucht, dass der Admin Beiträge eines anderen löscht, aber auch da war alles ok.
Wie es bei dir zu dem Status kam, kann ich bislang einfach nicht nachvollziehen und somit auch kein vernünftiges debugging betreiben.

Gruß

Edith: sehe gerade, dass 5?? Mails versendet werden. Das scheint mir etwas viel, Admin, Tester und ggf. Aufpasser sind doch nur 3, oder? Vielleicht kannst du ja mal in der DB nachschauen, was den dort als posts noch vermerkt ist.
« Last Edit: August 05, 2012, 09:30:21 PM by marmot »

Offline dbs

  • Betatester
  • **
  • Posts: 8076
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #92 on: August 05, 2012, 09:49:08 PM »
In der DB stehen 20 Posts. Also die richtige Anzahl.
Habe den Count nun mal angepasst und werde es beobachten, ansonsten mal ne saubere Installation versuchen.
Bei den letzten Tests ist mir die Masse an Mails auch aufgefallen, bin vielleicht gar nicht auf den letzten Stand... *grummel*

Offline iradj

  • Posts: 353
  • Gender: Male
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #93 on: October 29, 2012, 03:09:42 PM »
Weiß jemand, wo ungefähr die vernünftige Grenze für die Forumsmitglieder ist? 100, 1000, 5000 oder 10000?

Grüße Iradj

Offline svsanchez

  • Posts: 486
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #94 on: May 29, 2013, 08:24:08 AM »
Hallo! Wo ist das WB-Forum English topic bitte?

Offline svsanchez

  • Posts: 486
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #95 on: May 31, 2013, 01:41:35 AM »
Kein Englisch topic  :?

Offline dbs

  • Betatester
  • **
  • Posts: 8076
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #96 on: May 31, 2013, 06:26:21 AM »
You can start a english topic for WB-Forum 0.5 and all the peoples here will answer in english.  :wink:

Offline lugau45

  • Posts: 5
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #97 on: October 09, 2014, 07:51:30 PM »
Guten Tag zusammen, bei mir kommt nach der Installation nur:

Keine Foren vorhanden.
Erstellen Sie zunächst ein Forum auf der ersten Ebene.
In dieses Forum (wie in alle der ersten Ebene) können Sie nicht posten! Die erste Ebene dient der Gruppierung der Foren.
Was muss ich da wie anlegen?

Offline dbs

  • Betatester
  • **
  • Posts: 8076
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #98 on: October 09, 2014, 08:19:46 PM »
Hallo, in den bisherigen Antworten nichts gefunden?
Schau mal bei Antwort #82

Offline lugau45

  • Posts: 5
Re: WB-Forum 0.3 -> WB-Forum 0.5
« Reply #99 on: October 11, 2014, 11:12:18 AM »
Ja das ist ja das Problem wie geht das?
Ich habe ein Forum erstellt test, dann gespeichert. Dann komme ich auf die Übersichtsseite wo ich ein neues Forum erstellen kann oder unten auf test klicken kann. Aber wo kann ich ein Unterforum erstellen?

 

postern-length