Author Topic: Nuova versione e problemi  (Read 3710 times)

Offline pinuxio

  • Posts: 13
Nuova versione e problemi
« on: November 23, 2011, 08:46:28 PM »
Salve, volevo porvi una cosa strana installando la nuova versione di wsb su easyphp5.4alpha 3 mi da questo errore

Deprecated: Function get_magic_quotes_gp c() is deprecated in C:\Programmi\EasyPHP-5.4alpha3\www\prove\framework\class.wb.php on line 190

da cosa può dipendere? la versione di WebsiteBaker è la seguente

WebsiteBaker_2.8.2_SP1 :mrgreen:

Offline kweitzel

  • WebsiteBaker Org e.V.
  • **
  • Posts: 6983
  • Gender: Male
Re: Nuova versione e problemi
« Reply #1 on: November 23, 2011, 08:52:13 PM »
This is a warning of PHP itself: http://php.net/manual/en/security.magicquotes.php

saluti

Klaus

Offline pinuxio

  • Posts: 13
Re: Nuova versione e problemi
« Reply #2 on: November 24, 2011, 12:41:54 PM »
non essendo molto pratico di inglese e di php deduco che devo aggiungere queste due righe nel php.ini di conf di easyphp esatto?

Offline kweitzel

  • WebsiteBaker Org e.V.
  • **
  • Posts: 6983
  • Gender: Male
Re: Nuova versione e problemi
« Reply #3 on: November 24, 2011, 01:01:57 PM »
Il problema e' la versione di PHP utilizzata. Il messaggio appare perche' nelle versioni successive questa funzione non sara' piu' disponibile.

Grazie a mia moglie per la traduzione ...

Saluti

Klaus

Offline pinuxio

  • Posts: 13
Re: Nuova versione e problemi
« Reply #4 on: November 24, 2011, 01:13:14 PM »
ringrazo vivamente la traduttricce,chiedo solamente cosa fare cioè che riga rimuovere o in che file e se rimanere alla vecchia versione di wbb perchè su remoto funziona bene ma i locale purtroppo no :(

Offline Mte90

  • Moderator
  • ***
  • Posts: 93
  • Gender: Male
  • Italian Section Moderator and Translator
Re: Nuova versione e problemi
« Reply #5 on: November 24, 2011, 05:02:13 PM »
il problema è molto semplice, php ti avvisa che una funzione di php non è più supportata è deprecata.
gli sviluppatori di wsb stanno lavorando per risolvere questi problemi ma puoi ignorare tranquillamente queste cose.
devi modificare la variabile per error reporting sul tuo php.ini
http://php.net/manual/en/function.error-reporting.php
questa è la spiegazione delal funzione.
se la usi in ambiente di sviluppo ma non devi creare moduli puoi anche metterla su E_NONE altrimenti E_WARNING.
questa è una valutazione che devi fare tu.
www.mte90.net - Debian, Kde e programmazione!
Mp per richieste personali verranno cestinate!

 

postern-length