Author Topic: WebisteBaker 2.8.2 on Windows 2008 with FastCGI  (Read 5368 times)

Offline scheltel

  • Posts: 48
WebisteBaker 2.8.2 on Windows 2008 with FastCGI
« on: August 11, 2011, 12:03:24 PM »
Hi,

I'm trying to install WebsiteBaker 2.8.2 on a Windows 2008 Webserver with PHP (5.3.6.0) FastCGI. According the information in the Install form the prerequisites are met (see attachment). And when the Install form is submitted a config.php file is created. But after that a blank screen (/install/save.php) is shown.

When I try to access the site on the server I'm getting the following error message:
Quote
PHP Fatal error:  Call to undefined function mysql_connect() in [basefolder websites]\[site name]\framework\class.database.php on line 61

Any ideas what can be wrong?

[gelöscht durch Administrator]

Offline badknight

  • WebsiteBaker Org e.V.
  • **
  • Posts: 819
  • Gender: Male
    • pinzweb
Re: WebisteBaker 2.8.2 on Windows 2008 with FastCGI
« Reply #1 on: August 11, 2011, 12:08:51 PM »
Hi,

I'm trying to install WebsiteBaker 2.8.2 on a Windows 2008 Webserver with PHP (5.3.6.0) FastCGI. According the information in the Install form the prerequisites are met (see attachment). And when the Install form is submitted a config.php file is created. But after that a blank screen (/install/save.php) is shown.

When I try to access the site on the server I'm getting the following error message:
Quote
PHP Fatal error:  Call to undefined function mysql_connect() in [basefolder websites]\[site name]\framework\class.database.php on line 61

Any ideas what can be wrong?

look at the config.php is there something inside or is it empty?
Ich würde gern die Welt verändern, doch Gott gibt mir den Quellcode nicht...

Offline BlackBird

  • Posts: 2573
Re: WebisteBaker 2.8.2 on Windows 2008 with FastCGI
« Reply #2 on: August 11, 2011, 12:09:08 PM »
Apache webserver or IIS?

Offline scheltel

  • Posts: 48
Re: WebisteBaker 2.8.2 on Windows 2008 with FastCGI
« Reply #3 on: August 11, 2011, 12:14:12 PM »
Code: [Select]
<?php

define
(&#39;DB_TYPE&#39;, &#39;mysql&#39;);
define(&#39;DB_HOST&#39;, &#39;localhost&#39;);
define(&#39;DB_USERNAME&#39;, &#39;test&#39;);
define(&#39;DB_PASSWORD&#39;, &#39;test&#39;);
define(&#39;DB_NAME&#39;, &#39;wb_test&#39;);
define(&#39;TABLE_PREFIX&#39;, &#39;&#39;);

define(&#39;WB_PATH&#39;, dirname(__FILE__));
define(&#39;WB_URL&#39;, &#39;http://[site name]&#39;);
define(&#39;ADMIN_PATH&#39;, WB_PATH.&#39;/admin&#39;);
define(&#39;ADMIN_URL&#39;, &#39;http://[site name]/admin&#39;);

require_once(WB_PATH.&#39;/framework/initialize.php&#39;);

?>


I think this config.php looks fine.

Offline scheltel

  • Posts: 48
Re: WebisteBaker 2.8.2 on Windows 2008 with FastCGI
« Reply #4 on: August 11, 2011, 12:15:15 PM »
Apache webserver or IIS?

It's a Windows 2008 Web Server with FastCGI PHP.

Offline DarkViper

  • Forum administrator
  • *****
  • Posts: 3043
  • Gender: Female
Re: WebisteBaker 2.8.2 on Windows 2008 with FastCGI
« Reply #5 on: August 11, 2011, 12:15:36 PM »
It seems , thus whether the php-mysql client module is not installed.
That's way the function mysql_connect() can not be found.
Der blaue Planet - er ist nicht unser Eigentum - wir haben ihn nur von unseren Nachkommen geliehen

"You have to take the men as they are… but you can not leave them like that !" :-P
Das tägliche Stoßgebet: Oh Herr, wirf Hirn vom Himmel !

Offline BlackBird

  • Posts: 2573
Re: WebisteBaker 2.8.2 on Windows 2008 with FastCGI
« Reply #6 on: August 11, 2011, 12:23:55 PM »
Windows 2008 comes with IIS (Internet Information Services). But you can also install Apache on W2K8. So that's no answer. ;)

IIS is not supported by WB.

Offline scheltel

  • Posts: 48
Re: WebisteBaker 2.8.2 on Windows 2008 with FastCGI
« Reply #7 on: August 11, 2011, 12:33:29 PM »
It seems , thus whether the php-mysql client module is not installed.
That's way the function mysql_connect() can not be found.

The php-mysql client was not installed indeed. Thank you!

Offline scheltel

  • Posts: 48
Re: WebisteBaker 2.8.2 on Windows 2008 with FastCGI
« Reply #8 on: August 11, 2011, 12:34:27 PM »
Windows 2008 comes with IIS (Internet Information Services). But you can also install Apache on W2K8. So that's no answer. ;)

IIS is not supported by WB.

I want to try to install it on IIS 7 with FastCGI.