Author Topic: How to easily update from 2.8.1 to 2.8.2  (Read 71587 times)

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8364
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #50 on: August 10, 2011, 04:53:06 PM »
Hallo,

Quote
wenn die realtive Urls behalten willst, dann musst du in deinem Template die Pfade anpassen, indem du überall wo WB_URL steht.
halbe sätze kenne ich sonst nur von pete glocke  :-)


Man sollte halt nicht gleichzeitig telefonieren und einen Post verfassen. Womit mal wieder bewiesen wäre, dass Männer definitiv nicht multitaskingfähig sind.  :-D . Habs ausgebessert.

Danke

Matthias

Offline Luisehahne

  • WebsiteBaker Org e.V.
  • **
  • Posts: 4160
  • Gender: Male
    • Webdesign und Entwicklung WebsiteBaker
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #51 on: August 10, 2011, 04:54:41 PM »
Hi,

please write in english here.

In one of the next fixes the default will be absolute urls. Hope that will be ok for all.

Dietmar
Immer nur von der Zukunft reden, die Gegenwart vergessen und auf die Vergangenheit schimpfen
Neues Unwort: Schnappatmung

Offline carto

  • Posts: 12
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #52 on: August 10, 2011, 05:18:03 PM »
It is now getting worse than ever.

Whenever I want to view details of templates or modules in 2.8.2 I get the message :

Security offense!! Access denied!

What's my next step please.

Thank you

Offline carto

  • Posts: 12
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #53 on: August 10, 2011, 05:50:21 PM »
I kept working on my installation and I find the following :

If I look up for the template information in ADDONS I get an answer only for the new templates (round and blank)

Also I can change my pages templates to the following ONLY :

Default :Danfutrh business 3
Blank
Round

All my other templates are not functionnal.

Thanks

Offline nastytill

  • Posts: 63
  • Gender: Male
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #54 on: August 10, 2011, 06:10:26 PM »
Hallo,

Quote
hallo matthias,
unglaublich, ich weiß nicht wie, aber irgendwie habe ich es hinbekommen. meine HP läuft wieder. jetzt habe ich nur eine frage an dich. ich hatte vorher www.meineseite.de/wb/pages/index.php wenn ich da drauf geklickt habe, bin ich zu meiner home seite gekommen. jetzt geht das nicht mehr und er führt mich immer wieder auf die intro seite. das ist irgendwo was falsch, nur wo? danke dir im voraus.

Schön, dass wieder alles läuft. Das mit dem Link auf die Homepage ist eine Neuerung von WB 2.8.2. Hier die Erläuterung:

http://www.websitebaker2.org/forum/index.php/topic,22059.msg148653.html#msg148653

Standardmäßig ist WB jetzt auf relative Urls ( also ../../seite.php anstatt http://www.meineseite.de/wb/pages/seite.php) umgestellt. Das beschleunigt den Seitenaufbau. Man kann das aber in den Admin-Tools beim Frontend-Output Filter wieder auf absolute Urls umstellen (so wie es bisher immer war). Wenn du auf absolute Urls umstellst, brauchst du nichts weiter machen, wenn du die realtive Urls behalten willst, dann musst du in deinem Template die Pfade anpassen, indem du überall wo du WB_URL aufrufst einen slash / dranhängst.

z.B.:
Code: [Select]
<a href="<?php echo WB_URL?>">Home</a>ändern in:
Code: [Select]
<a href="<?php echo WB_URL?>/">Home</a>
Matthias

P.S. Lade sicherheitshalber nochmal alle Dateien vom changed_paket (siehe erste Post) auf deinen Server und starte bitte nochmals das darin enthaltende upgrade-script.

hallo matthias,
danke dir für die info. jetzt bin ich beruhigt.
aber ich glaube ich lass das jetzt so. bin glücklich, dass wieder alles läuft.
als ich das upgrade skirpt ausgeführt hat er mirr 22 neue tabellen in die datenbak geschrieben und gesagt wäre alles ok.
da ich eine intro seite benutze habe ich jetzt auf der intro einfach das pages/index.php in pages/home.php geändert. jetzt geht es. soll ich jetzt so alles alles alassen oder rätst du mir was anderes? danke.
OHNE HUB KEIN SCHUB !

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8364
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #55 on: August 10, 2011, 08:51:01 PM »
Hallo,

I answer in English, as we are in the english part. Forgot this in the posts above.

Quote
auf der intro einfach das pages/index.php in pages/home.php geändert.

So you named your first page "Index". If this was the case the index.php wich comes with the WB-Package and wich is a needed system file is overwritten with your file. this causes, that WB cannot work correct. So please upload all index.php from root an pages-directory from the Original WB package to your installtion.

Matthias

Offline webby

  • Posts: 86
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #56 on: August 14, 2011, 07:26:26 PM »
Hi

I'm getting this error when I try to run the upgrade-script.php?
(I have stricly followed the upgradeprocedure as told)

Fatal error: Call to undefined function: date_default_timezo ne_set() in /home/httpd/vhosts/hobrocaravan.dk/httpdocs/framework/initialize.php on line 25

What is wrong? Any suggestions?

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8364
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #57 on: August 14, 2011, 07:49:40 PM »
Hello,

wich php Version is running on your server? WB requires minimum PHP 5.2.2.

Matthias

Offline webby

  • Posts: 86
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #58 on: August 14, 2011, 09:40:49 PM »
Hi

Okay - thats the problem. This server runs only PHP 4.3.2...
Is there any way to roll the upgrade back?

:)

Offline webby

  • Posts: 86
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #59 on: August 15, 2011, 06:45:42 AM »
Hi again

It is possible for me to move the site to an PHP 5.2.5 server... Will the upgrade-script work as it looks now? (as told I have just uploaded the "WebsiteBaker-2.8.2_changed_files.zip" and moved the old files as told. The only thing left is to run the upgrade-script?). Or has the upgrade-script damaged the site?

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8364
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #60 on: August 15, 2011, 07:28:24 AM »
@webby

If you are on the php 5.2.5 server, simply run the upgrade script again.

Have fun

Matthias

Offline webby

  • Posts: 86
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #61 on: August 16, 2011, 09:01:51 AM »
Okay - it works...! :)

But there is a little other problem with one of the other website I have newly updated. The search-funktion on the frontend now gives an error when I try to search the site:

Parse error: syntax error, unexpected T_FUNCTION in /data/www/www.naturefterskolen.dk/w/modules/imagegallery/search.php on line 15...
It works perfect before the upgrade 2.8.1 to 2.8.2 ?

What can do to solve this you think?

:)

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8364
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #62 on: August 16, 2011, 10:47:39 AM »
Hello,

wich version of imagegallery?

Matthias

Offline webby

  • Posts: 86
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #63 on: August 16, 2011, 10:54:00 AM »
Hi

2.0.0 ?

:)

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8364
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #64 on: August 16, 2011, 11:25:20 AM »
Hello,

in the original imagegallery 2.0.0 package exists no file with the name search.php. It seems, that you have no original version. From where did you have the search.php.

Matthias


Offline webby

  • Posts: 86
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #65 on: August 16, 2011, 11:29:52 AM »
HI

Hmm - I don't really know that. I think it's the default one???

:)

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8364
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #66 on: August 16, 2011, 12:11:14 PM »
Hello,

the search.php files are created for different modules from the forum member thorn. The latest search.php files for the modules can be found on his projekt page.

http://nettest.thekk.de/doku.php/projects/searchext/start

Please compare, if your search.php is the same as the one from his page.

Matthias

Offline webby

  • Posts: 86
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #67 on: August 16, 2011, 12:28:59 PM »
Hi

Now I have updated the search.php from the forum member thorn. They where different from each other.
I have tried to overwrite the old search.php and know the error message desapear, but the search-engine still not work correctly (blank site/search field on the site).
I have also tried what they said on the member thorn : "Just download the corresponding “search extension”-module below and install the zip-file as usual like a regularly module" - with the same results - not working?

Hmmm ? :)

Offline webby

  • Posts: 86
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #68 on: August 16, 2011, 11:19:19 PM »
Hi again

Any suggestion how to get the search-funktion work again?

:)

Offline webby

  • Posts: 86
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #69 on: August 17, 2011, 10:16:49 AM »
Damm new problem... !

My contact-form on the newly updated web, do not work (do not send)?
Any idea what that is?

Thanks :)

Offline webby

  • Posts: 86
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #70 on: August 17, 2011, 10:22:34 AM »
- and now I can se this error on the bottom of the backend-form-admin:

"Error in my_thread_global_en d(): 1 threads didn't exit"  ?

:)

Offline quinto

  • Posts: 103
    • http://www.clubnumeric.org/
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #71 on: August 18, 2011, 05:37:20 PM »
Hello, can i upgrade directly to a 2.8.0 version ton 2.8.2, it's not clearly explained and i do not want to make a mistake, i need to upgrade a 2.8.0 to 2.8.2...

Offline Craxx

  • Posts: 259
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #72 on: August 26, 2011, 09:37:24 AM »
Hy ruebenwurzel,

Du hast geschrieben dass man von ner Version 2.8.1
Revision 1287 auf die 282 upgraden kann... ich habe die Version 2.8.1
Revision 1285. Muss ich da noch was beachten?
Hoffe das ist keine blöde Frage:)

Herzlichen Dank
Craxx;)
Craxx;)

Offline webby

  • Posts: 86
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #73 on: August 26, 2011, 05:16:04 PM »
Matthias help me please! :)

I've got the error: Safety Risk: Access denied" when I try to work with the backend (sometimes... and in other browsers it works!?). But how to correct this error?

I have read about the inserting of the "{FTAN}" markup in all forms in the backend theme, but this is a little confusing to me... How to do it ecactly? I've check both the backend themes and the markup sims to be in there already!?

Thank you very much :)

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8364
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: How to easily update from 2.8.1 to 2.8.2
« Reply #74 on: August 27, 2011, 01:02:26 AM »
@webby

if you use WB 2.8.2 you don't need to change anything (adding FTAN ..) as in WB 2.8.2 all is included in the backend_themes wich come with WB 2.8.2.

So where did you have your problems?

Matthias