Author Topic: :? Fehler beim anlegen der Seiten  (Read 1797 times)

Offline xnetworker

  • Posts: 24
  • Gender: Female
:? Fehler beim anlegen der Seiten
« on: February 24, 2010, 03:54:20 PM »
Ich habe die neu erstellten Seiten aus der Testumgebung in das Hauptverzeichnis kopiert.
Nun bekomme ich filgenden Fehler beim anlegen der neuen Seite:
"Beim Anlegen der Zugangsdatei im Verzeichnis /pages ist ein Fehler aufgetreten (Ungenügende Zugangsrechte)"

Obwohl ich in den Einstellungen am Anfang alles im Hauptverzeichnis speichern lasse. Ich finde weder in der Datenbank noch in der config-Datei einen Hinweis wo der Pfad zu /pages noch drin steht.

HAbe soeben nochmal alle Seiten gelöscht. Im Adminoptionmenü steht unter Speicherordner kein Ordner mehr drin. Trotzdem bekomme ich beim anlegen einer neuen Seite die Fehlermeldung
Quote
Beim Anlegen der Zugangsdatei im Verzeichnis /pages ist ein Fehler aufgetreten (Ungenügende Zugangsrechte)

Wo ist der Pfad /pages noch hinterlegt?
« Last Edit: February 24, 2010, 05:22:06 PM by xnetworker »

wollinche

  • Guest
Re: :? Fehler beim anlegen der Seiten
« Reply #1 on: February 24, 2010, 08:55:25 PM »
Der Pfad ist uninteressant.

Wichtig sin die Rechte im Verzeichnis /pages -> und die sind nicht richtig / ungenügend gesetzt.

Zum Thema Rechte:
http://de.wikipedia.org/wiki/Chmod

http://www.orgapage.net/pages/server/linux/benutzerrechte.php


Offline xnetworker

  • Posts: 24
  • Gender: Female
Re: :? Fehler beim anlegen der Seiten
« Reply #2 on: February 24, 2010, 09:55:35 PM »
Nein falsch verstanden. Das Verzeichnis pages gibt es nicht mehr. Oder muss das Verzeichnis bleiben? Die Seiten sollen im root des Webservers liegen.

Offline Hans>NULL

  • Posts: 1386
  • Gender: Male
Re: :? Fehler beim anlegen der Seiten
« Reply #3 on: February 24, 2010, 10:01:45 PM »
Das Verzeichnis kann inkl. / heißen wie es will, sonst bräuchte es die Option nicht.
So kann auch die Option Extention z.B. statt php auch ".saidevonmeinedomai n" heißen
Gruß, Hans>NUL
« Last Edit: February 24, 2010, 10:05:02 PM by Hans>NULL »
/dev/null Ort ohne Wiederkehr

Offline xnetworker

  • Posts: 24
  • Gender: Female
Re: :? Fehler beim anlegen der Seiten
« Reply #4 on: February 24, 2010, 10:03:57 PM »
Ja eben. Trotzdem besteht das Problem das keine Datei angelegt werden kann und er das Verzeichnis Pages anmeckert obwohl er im roo speichern soll.

Offline Hans>NULL

  • Posts: 1386
  • Gender: Male
Re: :? Fehler beim anlegen der Seiten
« Reply #5 on: February 24, 2010, 10:09:55 PM »
Quote
Testumgebung in das Hauptverzeichnis kopiert.
Testumgebung: Glaskugel?
Hauptverzeichnis: Glaskugel?
/dev/null Ort ohne Wiederkehr

Offline xnetworker

  • Posts: 24
  • Gender: Female
Re: :? Fehler beim anlegen der Seiten
« Reply #6 on: February 24, 2010, 10:11:54 PM »
Testumgebung: http://www.gasthof-grossnaundorf.de/neu/    -> also nur ein Unterordner
Hauptverzeichnis: http://www.gasthof-grossnaundorf.de   -> also root des Webspace

Offline Hans>NULL

  • Posts: 1386
  • Gender: Male
Re: :? Fehler beim anlegen der Seiten
« Reply #7 on: February 24, 2010, 10:14:30 PM »
War der Inhalt vorher unter /pages ???
Soweit ich erinnere klappt das mit ROOT nur BEVOR man irgendeine Seite anlegt.
Warte mal ab. Da werden sich noch welche melden, die das schonmal bearbeitet haben.
Habe diese Situation noch nicht getestet, daher kein kurzfristiges Lösungsangebot.
/dev/null Ort ohne Wiederkehr

Offline xnetworker

  • Posts: 24
  • Gender: Female
Re: :? Fehler beim anlegen der Seiten
« Reply #8 on: February 24, 2010, 10:33:35 PM »
Problem hat sich gelöst.

Habe nochmals /pages als Verzeichnis eingetragen. -> Eine Seite erstellt. -> alle Seiten gelöscht -> dann wieder Standardverzeichnis s geändert (/pages gelöscht) -> siehe da, es klappt nun