Author Topic: slideshow and jquery not working!  (Read 3758 times)

zombies

  • Guest
slideshow and jquery not working!
« on: December 13, 2009, 01:21:29 AM »
Hi

I am converting (trying to!) a template to WB

I have a slideshow in there and also jquery menu

head code -
Code: [Select]
<!-- //      Javascript Files For Menu Top        // -->
<script type="text/javascript" src="<?php echo TEMPLATE_DIR?>/js/jquery.js" ></script>
<script type="text/javascript" src="<?php echo TEMPLATE_DIR?>/js/jquery.easing.min.js" ></script>
<script type="text/javascript" src="<?php echo TEMPLATE_DIR?>/js/js.js"  ></script>

<!-- //      Javascript Files For booking        // -->
<script type="text/javascript" src="<?php echo TEMPLATE_DIR?>/booking.js" ></script>

<!-- //      Javascript Files For Slideshow Images        // -->
<script type="text/javascript" src="<?php echo TEMPLATE_DIR?>/js/jquery_cycle.js" ></script>
<script type="text/javascript">
<!--
$(function() {
    $('#slideshow img:first').fadeIn(700, function() {
        $('#slideshow').cycle();
    });
});
//-->
</script>

slideshow bit -
Code: [Select]
<div id="header">
                <!-- BEGIN SLIDER -->
                <div id="slides_container">
                  <div id="slideshow" class="pics"> <img src="<?php echo TEMPLATE_DIR?>/images/2.jpg" alt="Slideshow" width="433" height="228"/> <img src="<?php echo TEMPLATE_DIR?>/images/01.jpg" alt="Slideshow" width="433" height="228"/> <img src="<?php echo TEMPLATE_DIR?>/images/3.jpg" alt="Slideshow" width="433" height="228"/><img src="<?php echo TEMPLATE_DIR?>/images/4.jpg" alt="Slideshow" width="433" height="228"/> <img src="<?php echo TEMPLATE_DIR?>/images/5.jpg" alt="Slideshow" width="433" height="228"/></div>
                    <!-- end of slideshow -->


menu bit -
Code: [Select]
               <div id="topmenu">
                    <div id="nav">
                        <ul class="lavaLamp" id="menu"><?php show_menu(101true, &#39;<li [current]>[a][menu_title][/a]&#39;, &#39;</li>&#39;, &#39;<ul>&#39;, &#39;</ul>&#39;, &#39;&#39;, &#39;class="active"&#39;); ?></div>
                      </ul>
                   
                </div><!-- end of topmenu -->

the first image shows on the slideshow but thats it, no fade, no change

and the menu highlights the active page but no sliding jquery gadgetry on the menu items

Any ideas?
« Last Edit: December 13, 2009, 01:26:44 AM by zombies »

Offline maverik

  • Posts: 1572
  • Gender: Male
  • ..:: viva los tioz ::..
Re: slideshow and jquery not working!
« Reply #1 on: December 13, 2009, 08:06:38 AM »
 i dont know the menu but cycle is working here http://www.jacks-vita.de

i think your call is wrong

my the call is

Code: [Select]
$('.pics').cycle({
    fx:     'fadeZoom, slideX,  wipe, growX, shuffle'

 });

you find all options here http://malsup.com/jquery/cycle/options.html

Offline Luisehahne

  • WebsiteBaker Org e.V.
  • **
  • Posts: 4359
  • Gender: Male
    • Webdesign und Entwicklung WebsiteBaker
Re: slideshow and jquery not working!
« Reply #2 on: December 13, 2009, 10:33:46 AM »
Can you post an url to have a look, what is wrong

Dietmar
Immer nur von der Zukunft reden, die Gegenwart vergessen und auf die Vergangenheit schimpfen
Neues Unwort: Schnappatmung

zombies

  • Guest
Re: slideshow and jquery not working!
« Reply #3 on: December 13, 2009, 12:46:41 PM »
Hi

The site is not online at the moment, no point setting it all up if I cant get some of the things working, may do without cms.

It does work fine in its normal html mode.


zombies

  • Guest
Re: slideshow and jquery not working!
« Reply #4 on: December 13, 2009, 03:20:35 PM »
Apart from the slideshow

I am trying to get this to work

http://www.gmarwaha.com/blog/category/client-side/jquery/

maybe a javascript conflict