WebsiteBaker Community Forum

WebsiteBaker Support (2.8.x) => General Help & Support => Topic started by: peitman on September 13, 2018, 01:19:51 PM

Title: 2.8.3 Inhalte verschwunden
Post by: peitman on September 13, 2018, 01:19:51 PM
Hallo zusammen,

von der Website sind Inhalte verschwunden, ob wohl diese keiner im Backend gelöscht hat. Der wysiwyg_Editor ist leer!
Ich weis, das System ist alt, aber derzeitig wird eine neue Seite erstellt und die Arbeit wollte man sich sparen!

CMS Version 2.8.3
Revision 1611
Admin version 1.6

Besteht die Möglichkeit eines Eingriffs von Aussen?

Gibt es eine Anleitung zum Update von 2.8.3 auf 2.12?

Schon mal Danke, für die Posts hierrauf.
Title: Re: 2.8.3 Inhalte verschwunden
Post by: hgs on September 13, 2018, 01:23:19 PM
Gibt es ein Backup durch den Hoster? oder von dir selber gemacht (Modul Backup z.B.)
Ich kann gerne mal Draufschauen
Dazu benötige ich Einlogdaten per PN als

Superadmin
und Zugangsdaten
DB
und
FTP-Zugangsdaten
Title: Re: 2.8.3 Inhalte verschwunden
Post by: peitman on September 13, 2018, 01:44:41 PM
Hallo Harald,
erst mal Danke für deine Antwort.
Ich habe lediglich ein Backup von der Datenbank am 10. Juli 2018 erstellt.

Was noch hinzu kommt, egal was ich im Backend anklicke, es öffnet sich immer eine neue Browserseite!

gruß Dirk
Title: Re: 2.8.3 Inhalte verschwunden
Post by: jacobi22 on September 13, 2018, 02:01:49 PM
benutzt du eine .htaccess (in genau dieser Schreibweise mit Punkt vorne dran?)
Falls JA, bitte mal umbenennen in htaccess.txt

Wenn du mich fragst, gibt es hier eine Mischung zwischen Charset-Problem (Editor leer) und PHP-Fehlern, die man wahrscheinlich zu hauf in der serverseitigen error.log findet. Möglicherweise wurde dazu auch noch die PHP-Version hochgesetzt. Eine WB 1611 läuft nur noch, wenn der Server eine 5er PHP-Version hat und dort auch das alte mysql (anstelle von mysqli) zur Verfügung stellt. Beides ist mittlerweise recht selten.

Entweder du bastelst schnell eine HTML-Übergangsseite oder du kommst um das Upgrade nicht herum
Title: Re: 2.8.3 Inhalte verschwunden
Post by: hgs on September 13, 2018, 02:11:12 PM
Quote
Ich weis, das System ist alt, aber derzeitig wird eine neue Seite erstellt und die Arbeit wollte man sich sparen!
Wird die neue Seite auch mit WebsiteBaker erstellt?

Quote
Gibt es eine Anleitung zum Update von 2.8.3 auf 2.12
Die neue Version 2.13 (zur Zeit im intensieven Test) wird ein upgrade von WB 2.8.3 rev 1611 in einem Rutsch durchführen.
Für die aktuelle version 2.12 haben wir das nie getestet, deshalb kann ich dazu nichts sagen.

Wlche php-Version läuft denn aktuell auf dem Server?
Title: Re: 2.8.3 Inhalte verschwunden
Post by: peitman on September 13, 2018, 02:14:37 PM
Eine  .htaccess verwende ich nicht.

Die PHP-Version ist 5.2

Die neue Seite wird mit wbce erstellt und läuft auch schon stabil auf dem gleichen Server. Allerdings ist diese noch nicht ganz fertig!
Title: Re: 2.8.3 Inhalte verschwunden
Post by: peitman on September 14, 2018, 09:38:37 AM
Hallo zusammen,

ich habe nun auf 2.10 upgedatet, dann auf 2.11. Auf 2.11 wurde nichts mehr außer das leere Template angezeigt!
Wieder zurück auf 2.10, Seite läuft.
Dann habe ich das Backup der Datenbank aus Juli eingespielt über phpMyAdmin und es erscheint die nachfolgende Meldung:


Statische Analyse:

2 Fehler wurden während der Analyse gefunden.

Unerwarteter Statement-Anfang. (near "phpMyAdmin" at position 0)
Unerkannte Statement-Typ. (near "SQL" at position 11)
SQL-Befehl:

phpMyAdmin SQL Dump -- version 4.7.7 -- https://www.phpmyadmin.net/ -- -- Host: mysql2.kevag-telekom.de -- Erstellungszeit: 10. Jul 2018 um 12:09 -- Server-Version: 10.1.26-MariaDB -- PHP-Version: 5.6.32-pl0-gentoo SET SQL_MODE = "NO_AUTO_VALUE_ON_ZE RO"

MySQL meldet: Dokumentation

#1064 - Fehler in der SQL-Syntax. Bitte die korrekte Syntax im Handbuch nachschlagen bei 'phpMyAdmin SQL Dump
-- version 4.7.7
-- https://www.phpmyadmin.net/
--
-- Host: ' in Zeile 1


So langsam verliere ich die Lust, ehrlich gesagt!
Der Fehler, dass sich alle Seiten im Backend in einem neuen Browser öffnen liegt anscheinend am Backend-Theme! argos- und wb-theme haben diesen Fehler, das Standard Theme funktioniert fehlerfrei.
Title: Re: 2.8.3 Inhalte verschwunden
Post by: dbs on September 14, 2018, 10:13:08 AM
Hallo, bist du sicher, dass du noch PHP5.2 da laufen hast? Wäre ziemlich fahrlässig von deinem Hoster.
Falls da was anderes läuft und evtl auch die Datenbank eine neuere Version hat, wirds schwierig.
Meine Empfehlung, such dir einen Portable, der noch die PHP Version hat, die du zuletzt benutzt hattest und mach dir damit deine Webseite wieder lauffähig.

Ohne Fehlermeldungen bei den Updates können wir schlecht helfen. Sollten im Root im Ordner var/logs zu finden sein.
Title: Re: 2.8.3 Inhalte verschwunden
Post by: peitman on September 14, 2018, 10:51:23 AM
Die php-Version gem. phpMyAdmin ist 5.6
Title: Re: 2.8.3 Inhalte verschwunden
Post by: hgs on September 14, 2018, 11:23:47 AM
Ab der version 2.10 sind die Backendtheme von 3.Anbietern nicht mehr lauffähig .
Nur noch das mitgelieferte Backendtheme bringt dir die tollen neuen Funktionen, die man bei "FremdCMSe" lange und umständlich suchen muß.

Vor 2 Jahren habe ich mal eine Seite von einem Forumsmitglied von WB 2.8.2 und php5.2 in 3 Schritten auf die damals aktuelle 2.12.0 gebracht.
Mein Angebot steht noch.
Von WB 2.8.3 geht es mit der Testversion 2.12.1 in einem Schritt, wenn die Datenbank sauber auf utf8 umgestellt ist.
Title: Re: 2.8.3 Inhalte verschwunden
Post by: ruebenwurzel on September 14, 2018, 12:06:09 PM
@peitmann

wenn du nach dem Update deine alte Datenbank eingespielt hast, solltest du den upgrade-script nochmals laufen lassen, wenn du ihn starten kannst (man muss als superadmin/admin mit der ID 1 angemeldet sein).

Matthias
Title: Re: 2.8.3 Inhalte verschwunden
Post by: peitman on September 14, 2018, 12:22:19 PM
@ Harald:Ich habe dir eine pers. Mitteilung geschickt
Title: Re: 2.8.3 Inhalte verschwunden
Post by: hgs on September 17, 2018, 01:42:04 PM
Zur Info
Die Probleme sind in der Testumgebung gefunden worden und auch schon gefixt.

Es lag unteranderem an einem Datenmischmasch von WB-Versionen (2.10 bis 2.12.0)
Das Template wurde angepasst.
Bei AnyNews wurde ein gepostetes Fix aus dem Forum eingebaut.