Author Topic: Unable to access media folder from WYSIWYG  (Read 138 times)

Offline KimCR

  • Posts: 12
    • Brisbane Hockey Association Inc
Unable to access media folder from WYSIWYG
« on: October 13, 2018, 05:38:40 PM »
Over recent days I upgraded a site from WB 2.8.3 SP7 to WB 2.10, then to WB 2.11. When I try to insert an image in a WYSIWYG section it does not load the media folder. I understand that this issue may have been previously raised when upgrading to WB 2.10 but that upgrading to WB 2.11 should have corrected it as it contained a number of "hot fixes".
WYSIWYG is v3.0.9 and CKEditor is v4.10.0.3.

In WYSIWYG I tap the "Insert Image" button:


After tapping "Browse Server" I get this:


Then if I tap "OK" I get this:


I have spent some time trying to find the issue but so far without a resolution. My guess is that it may be something to do with permissions but can't see what it is?

Any assistance would be greatly appreciated.
KimCR

Offline dbs

  • Betatester
  • **
  • Posts: 7490
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Unable to access media folder from WYSIWYG
« Reply #1 on: October 13, 2018, 06:20:30 PM »
Hi, i have the forum search used with "browser.html" and found this:
https://forum.WebsiteBaker.org/index.php/topic,30008.msg209468.html#msg209468
A entry in the .htacess

Hope it helps.

Offline KimCR

  • Posts: 12
    • Brisbane Hockey Association Inc
Re: Unable to access media folder from WYSIWYG
« Reply #2 on: October 14, 2018, 02:11:02 AM »
Thanks dbs! That sorted that issue. I can now see and can use the ckeditor file browser to browse the media folder.

However, it seems I'm not yet out of the woods with the media folder. Something I didn't notice before - I am prevented from creating new folders within the media folder from the main Media page. When I try to add a folder I receive a "Security offense!! Access denied!" message.

Also when trying to upload a file to a folder I receive a "[105] Security offense!! Access denied!" message.

Do you have any pointers on these issues as well?

Again any assistance is greatly appreciated.

KimCR

Offline KimCR

  • Posts: 12
    • Brisbane Hockey Association Inc
Re: Unable to access media folder from WYSIWYG
« Reply #3 on: October 14, 2018, 01:00:54 PM »
Update!
Tried upgrading to v2.12 but this hasn't altered this issue.

I note that I can delete a file in the media folder, but as before I cannot add a folder or upload a file.
Cheers,
KimCR

Offline dbs

  • Betatester
  • **
  • Posts: 7490
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Unable to access media folder from WYSIWYG
« Reply #4 on: October 14, 2018, 01:36:23 PM »
Do you have the same behavior with the DefaultTheme?
Your Argos theme hasn't been revised in a long time.

In Settings > Advanced Settings > Server
The permissions are 755 and 644?

Via FTP all files have  644 and folders 755?

Offline jacobi22

  • Posts: 5057
  • Gender: Male
  • Support only via PM or EMail
    • Jacobi22
Re: Unable to access media folder from WYSIWYG
« Reply #5 on: October 14, 2018, 01:41:47 PM »
from my eyes some possible problem's

1. wrong permission to the media-folder
2. server secure settings are too strong (keyword: mod-secure)
3. old backend theme (wb-theme, argos-theme etc) without FTAN-Support

at first: do you use a .htaccess in your wb-root-folder or inside of the media folder? if YES, please rename (both) for a test, for example to htaccess.txt

then check your wb-settings, go to Settings -> Advanced Settings -> Serversettings
check there the name of the media-folder, default is /media

you can use your ftp-programm (if you have there this option) or you use a addon like this -> Ruud's Systeminfo to check the chmod-settings for the selected media folder (mostly right-mouse-click to the folder name, use chmod 755 or chmod 777,

after install Ruud's Addon look at Admintools-> System Informationen -> File Permission to see the actual permission
a good ftp-program give you also the information about the owner and group (not Filezilla), maybe you can use WebFTP for your account, to change owner and group, if different to other folders


Additional to the answer from dbs - the ARGOS-Theme in the old version doesn't support the FTAN-Proof-Method, without this FTAN, you get the Secure Warning (but you must have it nealy on every page inside the backend

Etwas ist nur unmöglich, wenn man glaubt, dass es das ist!

Offline KimCR

  • Posts: 12
    • Brisbane Hockey Association Inc
Re: Unable to access media folder from WYSIWYG
« Reply #6 on: October 14, 2018, 04:41:50 PM »
Working!!  I cannot thank both dbs and jacobi22 enough!

I had previously run fix-permissions.php over the site so the permissions should have been correct. However I checked them again, especially the"/media" folder - all were correct! My desktops are all Linux (Kubuntu) so I used gFTP to check it out - can recommend gFTP on Linux - looks and feels similar to the old WSFTP back in my dark days of using Windows.  :wink:

As suggested, I then changed the theme to "WebsiteBaker Default Theme v1.3.3.dev3" and all of the issues I was having appear to have vanished. I recall some time ago I was having difficulty with a "WebsiteBaker Default Theme" or "WB Theme" under version 2.8.3 SP7. I changed back to Argos to get things working at the time. Of course after upgrading this time around I made certain I was running the Argos theme again. I didn't understand the importance of running the newer backend theme - I do now!!  :oops:

Thank you again for your assistance!!

KimCR

 

postern-length