Author Topic: download_gallery module does not work  (Read 228 times)

Offline ismaelbonifacio

  • Posts: 11
download_gallery module does not work
« on: October 11, 2018, 09:23:44 PM »
I have WebsiteBaker 2.8.3 + SP7. I installed ubuntu 16.04 lts operating system and stopped working the addons or plugin download_gallery. I installed the version of this plugin 2.61, 2.66,2.74 I upload the file, but it is not visible publicly or privately. I tried to upgrade to WebsiteBaker 2.10, but the files that had the language (º, no, ...) could not be downloaded. I had to go back to version 2.8.3. Someone can help me?

Offline hgs

  • Betatester
  • **
  • Posts: 881
    • EFG MG
Re: download_gallery module does not work
« Reply #1 on: October 12, 2018, 02:33:06 AM »
Which php version is in use?
The Downloadgallery 2.74 works with php 5.6 to php 7.2 with WebsiteBaker 2.12 without any problems.
Upgrade from 2.8.3 to 2.10 (from here at least php5.6 is required!) And 2.11 to 2.12 and then install the download gallery from here:
https://addon.WebsiteBaker.org/pages/en/browse-add-ons.php?id=0291C731
LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

Offline ismaelbonifacio

  • Posts: 11
Re: download_gallery module does not work
« Reply #2 on: October 12, 2018, 03:39:05 AM »
It had a 2.8.3 version I installed download_gallery 274 and disappeared all the download files. To do the installation of 2.10 WebsiteBaker and install again the module download_gallery and remained the same, the menus and submenus are with another language, as words with the signs (º, ~, ^ ...) change all. I upgraded to version 2.12 and stayed the same. Changed on the premises php 5.6 to 7.1 and vice versa and did not grow, does not appear in the download files and gives errors in the language.

Offline ismaelbonifacio

  • Posts: 11
Re: download_gallery module does not work
« Reply #3 on: October 12, 2018, 03:48:25 AM »
I limited the download of the zipped folder 2.10 WebsiteBaker, after opening, to a folder of my website based on a website, I called the link www.meu domain.com/site/install everything went okay the uth8 disable then I installed download_gallery274 and one of the times the download files of the site were empty and again off. Upgrading also gives error in the menus and submenus in the language. Words with accent marks are changed throughout the site.

Offline jacobi22

  • Posts: 5057
  • Gender: Male
  • Support only via PM or EMail
    • Jacobi22
Re: download_gallery module does not work
« Reply #4 on: October 12, 2018, 11:33:22 AM »
only for interest... what is the default_charset on this server?

some servers has the option to show a phpinfo, Ruud has some modules like sysinfo, phpinfo  or you build a file with this content

Code: [Select]
<?php
phpinfo
();
?>

name it as info.php, load it to the server and call this file in your browser
Etwas ist nur unmöglich, wenn man glaubt, dass es das ist!

Offline ismaelbonifacio

  • Posts: 11
Re: download_gallery module does not work
« Reply #5 on: October 12, 2018, 09:57:51 PM »
Yes. I make this file and I have the php indication that is in use. It gets a listing of php that starts like this:
System    Linux 4.4.0-138-generic #164-Ubuntu SMP Wed Oct 3 15:02:00 UTC 2018 i686
Server API    Apache 2.0 Handler
Virtual Directory Support    disabled
Configuration File (php.ini) Path    /etc/php/5.6/apache2
Loaded Configuration File    /etc/php/5.6/apache2/php.ini
Scan this dir for additional .ini files    /etc/php/5.6/apache2/conf.d
Additional .ini files parsed    /etc/php/5.6/apache2/conf.d/10-mysqlnd.ini, /etc/php/5.6/apache2/conf.d/10-opcache.ini, /etc/php/5.6/apache2/conf.d/10-pdo.ini, /etc/php/5.6/apache2/conf.d/15-xml.ini, /etc/php/5.6/apache2/conf.d/20-calendar.ini, /etc/php/5.6/apache2/conf.d/20-ctype.ini, /etc/php/5.6/apache2/conf.d/20-curl.ini, /etc/php/5.6/apache2/conf.d/20-dom.ini, /etc/php/5.6/apache2/conf.d/20-exif.ini, /etc/php/5.6/apache2/conf.d/20-fileinfo.ini, /etc/php/5.6/apache2/conf.d/20-ftp.ini, /etc/php/5.6/apache2/conf.d/20-gd.ini, /etc/php/5.6/apache2/conf.d/20-gettext.ini, /etc/php/5.6/apache2/conf.d/20-iconv.ini, /etc/php/5.6/apache2/conf.d/20-imagick.ini, /etc/php/5.6/apache2/conf.d/20-intl.ini, /etc/php/5.6/apache2/conf.d/20-json.ini, /etc/php/5.6/apache2/conf.d/20-mbstring.ini, /etc/php/5.6/apache2/conf.d/20-mcrypt.ini, /etc/php/5.6/apache2/conf.d/20-mysql.ini, /etc/php/5.6/apache2/conf.d/20-mysqli.ini, /etc/php/5.6/apache2/conf.d/20-pdo_mysql.ini, /etc/php/5.6/apache2/conf.d/20-phar.ini, /etc/php/5.6/apache2/conf.d/20-posix.ini, /etc/php/5.6/apache2/conf.d/20-readline.ini, /etc/php/5.6/apache2/conf.d/20-shmop.ini, /etc/php/5.6/apache2/conf.d/20-simplexml.ini, /etc/php/5.6/apache2/conf.d/20-sockets.ini, /etc/php/5.6/apache2/conf.d/20-sysvmsg.ini, /etc/php/5.6/apache2/conf.d/20-sysvsem.ini, /etc/php/5.6/apache2/conf.d/20-sysvshm.ini, /etc/php/5.6/apache2/conf.d/20-tokenizer.ini, /etc/php/5.6/apache2/conf.d/20-wddx.ini, /etc/php/5.6/apache2/conf.d/20-xmlreader.ini, /etc/php/5.6/apache2/conf.d/20-xmlwriter.ini, /etc/php/5.6/apache2/conf.d/20-xsl.ini

default_charset   UTF-8   UTF-8

Offline ismaelbonifacio

  • Posts: 11
Re: download_gallery module does not work
« Reply #6 on: October 12, 2018, 10:01:20 PM »
default_charset   UTF-8   UTF-8

Offline ismaelbonifacio

  • Posts: 11
Re: download_gallery module does not work
« Reply #7 on: October 12, 2018, 11:17:33 PM »
I have the WB Version 2.8.3+SP7 (r1647), and

 Download Gallery
Tipo:    Página
Autor:    Hudge, Woudloper, M. Gallas, R. Smith, C. Sommer
Versão:    1.91
Designado para:    Website Baker 2.7
Descri&ccdil;ão:    This page type is designed for making a download gallery page.

Offline jacobi22

  • Posts: 5057
  • Gender: Male
  • Support only via PM or EMail
    • Jacobi22
Re: download_gallery module does not work
« Reply #8 on: October 13, 2018, 11:55:22 AM »
I tried to upgrade to WebsiteBaker 2.10, but the files that had the language (º, no, ...) could not be downloaded.

do you have the special chars inside of the file names?
if YES, please read some informations about the rules for filenames and foldernames

some infos about names for files and folders and in summary for path's
max file name lenght: 255 chars
max path lenght: 4096 chars
allowed chars: A B C D E F G H I J K L M N O P Q R S T U V W X Y Z a b c d e f g h i j k l m n o p q r s t u v w x y z 0 1 2 3 4 5 6 7 8 9 . _ -
minimum size for a filename: 1 byte

some chars are placeholders or chars with a special function - never start a file- or foldername with - or /
. and .. are some special chars  - the single point for invisible files + folders , the double point are only for path's

Ubuntu can also handle folder- and filenames and path's with these chars:  \ : * ? " < > |
but not possible, to use the same names in other operation systems like Windows

---------------------------------------------------

in combination with the charset on the used page inside of back- or frontend, the script try to translate the (not allowed) chars into allowed chars, simple example is the %20 for a white space in a filename like this  "example file.jpg" show's in a browser as "example%20file.jpg"
the same for every other special char like accent marks etc. keyword is here URL-Encoding

the other case are special chars inside of text (no file-or foldername to use it in a browser as URL)
a language file needs a special format, for WB (and nearly all other modern systems) UTF8 is the standard. WB has the possibility, to handle different language files at the same time, so the english language is loaded every time and work as a backup, all other language variables come's from another language file, defined in WB- or in User settings

to add a new language, make a copy of your favorite language file in wb-folder /language or from the language files from special addon, for example the download gallery in modules/download_gallery/languages. In my version, i have there at the moment 4 files, EN.php, DE.php, NL.php, FR.php. if i need now a translation to swedish, i make a copy from the file EN.php and rename it to SE.php
than i've to open this file with a editor like notepad++ etc and translate row by row. Be sure, that the editor has the correct setting to convert files utf8 without boom. With these setting, you can write in the editor in your own language and the intern translator convert the special chars to real UTF8 - that's important for WB
for example some word's from my actual project
in german - Entenfrühstücksflei sch
in real UTF8 - Entenfrühstücksfl eisch

other example:  normal: Página - in utf8: Página

if you need a new language for the backend, make at first a copy from a file inside of the wb-language-folder /languages
copy this file into another folder  - recommended, a empty folder
Use ISO 3166-1 language codes (2 characters) -> https://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 to found the correct language code

important for a new language file is these block here: (copied from PT.php (portuguese)

Quote
$language_code = 'PT';
$language_name = 'Portuguese (Brazil)';
$language_version = '4.0.0';
$language_platform = '2.11.0';
$language_author = 'Manuela v.d.Decken, Dietmar Wöllbrink';
$language_license = 'GNU General Public License 2.0';

very important is here the first row with the country code (here PT). For example: if i need a file for India, i change this line to IN and rename the file to IN.php. It's important, that the language code and the file name is equal.
After that, i can translate step by step everything in this new file to my favorite language.
if you're finish with the translation, zip this single file and install it as a new language under addons->language-> install language

after the install, you can select the "new" language in WB-Settings and in User Settings (Profile)
and now, you can build a special language file with the same name for the addon, it's not needed to install this new addon language, it's enough, if you copy this file into the languages-folder from the addon. wb select automatically this file, if this language is selected as your user language and (in frontend) set as the page language

if you want to change something from the existed language files, make at first a backup copy from this file somewhere on your locale machine.
since wb 2.10.x it's possible to clear the language cache. for that, click on the Link "Clear Translate Cache" in infowindow (i-Button in top menu). you have to ddo this everytime, when you change something in language files.

to download_gallery:
the original download_gallery add a folder protection file, called .htaccess into the folder /media/download_gallery.
rename this file to htaccess.txt for your test's

if this post doesnt solve your problems, maybe you can give a better description for the problems, screenshots are very helpfull.
And work step by step. it's difficult to help, if you write hundred's of problems in one single post
Etwas ist nur unmöglich, wenn man glaubt, dass es das ist!

Offline ismaelbonifacio

  • Posts: 11
Re: download_gallery module does not work
« Reply #9 on: October 13, 2018, 02:08:04 PM »
Thanks for the information. I installed everything new with a new database, WebsiteBaker version 2.10, with php5.6 and download_gallery 2.74 and does not fix the files download. So the problem should be the configuration of ubuntu or php.

Offline jacobi22

  • Posts: 5057
  • Gender: Male
  • Support only via PM or EMail
    • Jacobi22
Re: download_gallery module does not work
« Reply #10 on: October 13, 2018, 02:18:29 PM »
what means
Quote
and does not fix the files download

- not possible to upload?
- no links in database table mod_download_galler y_files - field "link"?
- no entrys in this database table?

if the database is okay and you have all datas complete for one download, maybe it's a permission problem with the folder /media/download_gallery - check the owner- and user rights for this folder and compare it with other wb-folders, maybe from modules/download_gallery

and if you start with a new installation in a new folder with a new database, why not the latest version? WB 2.10 is from 03/2017. there is a newer version 2.11 and (recommended) Vers 2.12
and if you ask the dev for a link, you can also test the next generation 2.13
Etwas ist nur unmöglich, wenn man glaubt, dass es das ist!

Offline ismaelbonifacio

  • Posts: 11
Re: download_gallery module does not work
« Reply #11 on: October 13, 2018, 07:16:24 PM »
I can not install the latest version of WebsiteBaker, because I have other applications that only run on php5.6. Is there a module I can replace to attach files for download? Any module to replace download_gallery? It stopped working on all versions of WebsiteBaker and running with php7.2, 7.1. The download_gallery module in ubuntu 16.04 crashed. If anyone knows of another module to insert files to download and that replace this module thanked that they sent the link to me.

Offline jacobi22

  • Posts: 5057
  • Gender: Male
  • Support only via PM or EMail
    • Jacobi22
Re: download_gallery module does not work
« Reply #12 on: October 14, 2018, 01:20:10 AM »
i give up!
no answer for my questions, no details about the problem. i use the download gallery in vers 2.6.2 in any projects with different php-version, everything between PHP 5.6 and PHP 7.2.9 and nearly every online server run's with ubuntu

good luck
Etwas ist nur unmöglich, wenn man glaubt, dass es das ist!

Offline evaki

  • Posts: 2107
Re: download_gallery module does not work
« Reply #13 on: October 14, 2018, 06:25:46 AM »
<offtopic>
Code: [Select]
Kleine Info: Apache kann auch "unicode-file name", wenn das Dateisystem des OS mitspielt, und läßt sich über htaccess einschalten.
Habe ich vorletzte Woche bei einer IDN-Domain gebraucht (File-Server).
Dummerweise produziert der Apache hierbei einen Darstellungsfehler beim DirectoryListing.
Apache ist nicht der Papst, sondern Indianer. :-o Macht aber nix, wenn man "unter PHP" arbeitet.
Das aber nur am Rande.
</offtopic>
MfG. Evaki
« Last Edit: October 14, 2018, 06:35:47 AM by evaki »
Einmal Pizza Quattro Stagioni bitte, aber ohne Herbst.

Offline hgs

  • Betatester
  • **
  • Posts: 881
    • EFG MG
Re: download_gallery module does not work
« Reply #14 on: October 14, 2018, 10:04:57 AM »
Ich kann das überhaupt nicht bestätigen, Die neuste, noch nicht veröffendlichte Version 2.12.1, läuft immer noch ohne Probleme mit php5.6.
Die DownloadGallery läuft bei mir in allen WB-Versionen von php5.6 bis php7.2

Wie sollen wir dir helfen, wenn du unsere Fragen nicht beantwortest?

DeepTranslate
I can't confirm that at all. The latest, not yet released version 2.12.1, still runs without problems with php5.6.
The DownloadGallery runs in all WB versions from php5.6 to php7.2.

How can we help you if you don't answer our questions?
LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

 

postern-length