Author Topic: Update auf WB Version 2.10.0-RC1  (Read 482 times)

Offline gurkenhals

  • Posts: 82
Update auf WB Version 2.10.0-RC1
« on: February 08, 2017, 11:56:26 AM »
Moin!

Gestern habe ich auf einem meiner Webserver das Update installiert. Alles grün, und sieht alles sehr gut aus! Allerdings taucht hier der gleiche Fehler mit dem Kontaktformular auf, wie schon beim Update auf das SP7 1647; nach Absenden einer Nachricht kommt der "Fehler: Server nicht gefunden". Die beiden Framework-Daten von jacobi22 brachten in diesem Fall keine Besserung (wahrscheinlich nur für v.2.8.3). Und das Bild-Captcha wird nicht angezeigt. Ansonsten macht alles erstmal einen sehr guten Eindruck!  (Y)

Die anderen Installationen der anderen Domains sind etwas umfangreicher (Droplets, Plugins, Templateänderungen, Galerien und sonstige Medieninhalte etc.). Dazu gibt es gegebenenfalls Rückmeldungen, wenn es Besonderheiten gibt.
« Last Edit: February 10, 2017, 08:56:48 AM by Luisehahne »

Offline dbs

  • Posts: 6784
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Update auf WB Version 2.10.0-RC1
« Reply #1 on: February 08, 2017, 12:03:25 PM »
Ohne diesen Post hätte ich gar nicht gewußt, dass es eine 2.10. zum Downloaden gibt.

Offline gurkenhals

  • Posts: 82
Re: Update auf WB Version 2.10.0-RC1
« Reply #2 on: February 08, 2017, 12:17:15 PM »

Offline Luisehahne

  • WebsiteBaker Org e.V.
  • Posts: 4021
    • Webdesign und Entwicklung WebsiteBaker
Re: Update auf WB Version 2.10.0-RC1
« Reply #3 on: February 08, 2017, 01:03:02 PM »
Ankündigung ist in Arbeit. Ihr wart uns zuvor gekommen. Aber bitte daran denken, dass die 2.10.0 RC1 nicht für den produktiven Einsatz gedacht ist und wir brauchen euer Feedback.

Dietmar
Eric T. Hansen, amerikanischer Buchautor „Nörgeln des Deutschen größte Lust"
Neues Unwort: Schnappatmung

Offline jacobi22

  • Posts: 4032
    • Jacobi22
Re: Update auf WB Version 2.10.0-RC1
« Reply #4 on: February 09, 2017, 03:10:34 AM »
Quote
Gestern habe ich auf einem meiner Webserver das Update installiert. Alles grün, und sieht alles sehr gut aus! Allerdings taucht hier der gleiche Fehler mit dem Kontaktformular auf, wie schon beim Update auf das SP7 1647; nach Absenden einer Nachricht kommt der "Fehler: Server nicht gefunden". Die beiden Framework-Daten von jacobi22 brachten in diesem Fall keine Besserung (wahrscheinlich nur für v.2.8.3)

schaut so aus als würde dieses Problem nur in bestimmten Konfigurationen auftreten.
könntest du bitte mal in den Quelltext dieses Formulars schauen, was da als Action-Url drin steht, hier im Bild aus dem Form-Modul orange markiert



mit Windows-System, rechte Maustaste im Browser und Quelltext anzeigen bzw Seitenquelltext anzeigen
Dann am einfachsten die Suche benutzen STRG + F und nach action suchen

Modulname, wo es auftritt, wäre noch wichtig und deine PHP-Version auf dem Server, wo es auftritt
Sofern wir vom gleichen Problem reden, ist das Problem schon lokalisiert
Du warst hier in meiner Seele und bist jetzt meilenweit entfernt
Wenn ich in Liedern von dir erzähle, war das jede Träne wert!
Alex Diehl- In meiner Seele

Offline gurkenhals

  • Posts: 82
Re: Update auf WB Version 2.10.0-RC1
« Reply #5 on: February 09, 2017, 07:59:10 PM »
Form Modul v3.1.3
PHP-Version: 7.0.15
Code: [Select]
<form style="float: none;" class="frm-formular" id="form10" action="//pages/kontakt.php" method="post">
Allerdings mit den "neuen" Framework-Daten von neulich, als es um das Update auf SP7 ging...

Offline jacobi22

  • Posts: 4032
    • Jacobi22
Re: Update auf WB Version 2.10.0-RC1
« Reply #6 on: February 09, 2017, 08:11:22 PM »
entweder das ganze RC-Paket drüber ziehen oder nur den Output-Filter davon  (modules/output_filter)

ist seit heut morgen im Paket gefixt
Du warst hier in meiner Seele und bist jetzt meilenweit entfernt
Wenn ich in Liedern von dir erzähle, war das jede Träne wert!
Alex Diehl- In meiner Seele

Offline gurkenhals

  • Posts: 82
Re: Update auf WB Version 2.10.0-RC1
« Reply #7 on: February 09, 2017, 11:36:10 PM »
Ok, danke, funktioniert!  (Y) :lol:

Offline Hollol

  • Posts: 198
Re: Update auf WB Version 2.10.0-RC1
« Reply #8 on: February 11, 2017, 03:26:23 PM »
Hi zusammen,

ich hab meine größte Page in der Testumgebung von 2.8.3+SP7 auf WB 2.10 upgegradet.

Lief sauber durch, ohne Auffälligkeiten.
Ansonsten ist mir bisher weder im Frontend, noch im Backend irgendwas aufgefallen.

Eine Kleinigkeit, die aber nicht ins Gewicht fallen dürfte:
Falls in einem Modul die Abfrage drin ist, ob die WB-Version kleiner 2.8 ist, wird ein Hinweis statt der Inhalte angezeigt. 2.10 wird kleiner definiert als 2.8.

Die Mailfunktionen kann ich leider lokal nicht testen.

Fazit: Upgrade funktioniert tadellos.


Grüße
Hollol



Offline DarkViper

  • Core Development
  • *****
  • Posts: 2799
Re: Update auf WB Version 2.10.0-RC1
« Reply #9 on: February 11, 2017, 03:42:54 PM »
Eine Kleinigkeit, die aber nicht ins Gewicht fallen dürfte:
Falls in einem Modul die Abfrage drin ist, ob die WB-Version kleiner 2.8 ist, wird ein Hinweis statt der Inhalte angezeigt. 2.10 wird kleiner definiert als 2.8.

Hast Du mir mal ein Beispiel, bei welchem Modul (Name, Version, Herkunft) das auftritt??

Manuela
Der blaue Planet - er ist nicht unser Eigentum - wir haben ihn nur von unseren Nachkommen geliehen

"You have to take the men as they are ... but you can not leave them like that !!" :-P
Ein einziger Buchstabendreher kann einen ganzen Satz urinieren.

Offline Hollol

  • Posts: 198
Re: Update auf WB Version 2.10.0-RC1
« Reply #10 on: February 11, 2017, 04:45:23 PM »
Quote from: DarkViper
Hast Du mir mal ein Beispiel, bei welchem Modul (Name, Version, Herkunft) das auftritt??

Hallo Manuela,

ich hatte diesen Code im Modul "AnyNews":
Quote
// output message for outdated Website Baker versions
      if ((double) WB_VERSION < 2.7) {
         echo $LANG[0]['TXT_REQUIREMENTS'];
         return;
      }

Ich weiß, das Modul (oder meine Version davon) ist uralt. Aber ich hatte es auf meine Bedürfnisse umgestrickt und es bleibt so lange noch drin, bis ich eine Alternative habe.
Da bei dem Modul der Hinweis kam, dachte ich, das kommt evtl. auch in anderen Modulen vor.

Edit: @version      1.16

Offline DarkViper

  • Core Development
  • *****
  • Posts: 2799
Re: Update auf WB Version 2.10.0-RC1
« Reply #11 on: February 11, 2017, 05:27:01 PM »
ich hatte diesen Code im Modul "AnyNews":

    
// output message for outdated Website Baker versions
    
if ((double) WB_VERSION 2.7) {
        echo 
$LANG[0]['TXT_REQUIREMENTS'];
        return;
    }
sowas dachte ich mir schon.. ;)

lässt sich aber relativ einfach ändern:

    
// output message for outdated Website Baker versions
    
if (version_compare(WB_VERSION'2.7''<')) {
        echo 
$LANG[0]['TXT_REQUIREMENTS'];
        return;
    }

und schon sollte es funktionieren...

have a nice day.. ;)
Der blaue Planet - er ist nicht unser Eigentum - wir haben ihn nur von unseren Nachkommen geliehen

"You have to take the men as they are ... but you can not leave them like that !!" :-P
Ein einziger Buchstabendreher kann einen ganzen Satz urinieren.

Offline Hollol

  • Posts: 198
Re: Update auf WB Version 2.10.0-RC1
« Reply #12 on: February 22, 2017, 04:54:21 PM »
Das "Danke" hatte ich vergessen. Sei hiermit nachgeholt  :wink:

Ich würde ja auch gerne was berichten und zur 2.10. beisteuern.
Aber inzwischen habe ich schon mehrere Sites lokal upgegradet und keine weiteren Probleme oder Auffälligkeiten festgestellt. Trotz zum Teil veralteter Module, ähem.

Zeugt von guter Arbeit. Großes Lob  (Y)

Offline jacobi22

  • Posts: 4032
    • Jacobi22
Re: Update auf WB Version 2.10.0-RC1
« Reply #13 on: February 22, 2017, 05:01:28 PM »
 (Y) (Y) + Dank

mach nicht ganz so viel - mit der Stable-Version (soll diese Woche noch kommen) gibt es noch einmal wichtige Änderungen aus den Tickets - brauchst du aber nur drüber kopieren
Du warst hier in meiner Seele und bist jetzt meilenweit entfernt
Wenn ich in Liedern von dir erzähle, war das jede Träne wert!
Alex Diehl- In meiner Seele

Offline Hollol

  • Posts: 198
Re: Update auf WB Version 2.10.0-RC1
« Reply #14 on: February 22, 2017, 06:42:02 PM »
Quote from: jacobi22
...mit der Stable-Version (soll diese Woche noch kommen)

Das sind ja erfreuliche Neuigkeiten.
Besten Dank für den Hinweis!

 (Y)

 

postern-length